Vote change should not ask to "change numbers" if there are none.

RESOLVED DUPLICATE of bug 159996

Status

()

Bugzilla
User Interface
P3
trivial
RESOLVED DUPLICATE of bug 159996
16 years ago
6 years ago

People

(Reporter: Andreas Krüger, Assigned: myk)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
 
(Reporter)

Comment 1

16 years ago
Created attachment 78720 [details] [diff] [review]
Fix, also removes table caption if table is empty.

Patch against 2.14.1
This patch has rotted, as votes have been templatised. Do we still need it, or
something like it?

Gerv
(Reporter)

Comment 3

16 years ago
"Do we still need it" - well:  Who is "we"?

As for me, I'm a customer of

   http://www.mozilla.org/projects/bugzilla/
and
   http://www.mozilla.org/projects/bugzilla/how_to_help.html

From my point of view, 2.14.1 is the current Bugzilla release.
No templates far and wide.  In that sense, this patch is fresh and alive.
It's in fact what I'm using at the site I administer.

On the other hand, it is likely the core Bugzilla development team has no need 
for this patch and, from the point of view of some internal CVS version, the 
problem has been fixed in a different manner (templates).  In that sense, this 
patch would be outdated.  Quite possibly so; personally, I don't know for sure.

I just read that page behind that second URL quoted above and tried to be 
helpful.

See also the discussion over at bug 120233, particularily comments 23-25.
Andreas, Gerv was not trying to say your efforts aren't appreciated or you did
something wrong, he was merely trying to ask anyone else whether it was still
needed because he was too busy (or too lazy) to look.

As for that, I'm too lazy and too busy too so I'll send this to 2.18 and someone
can work out if this bug is fixed.
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
(Reporter)

Comment 5

16 years ago
Matthew - thanks for your remark, and don't worry!

I might have sounded more frustrated than I am.
No offense intended, I'm sure - none taken, either!

Comment 6

16 years ago
As far as I understand, this has been fixed by the templatization, though not
exactly the way that 2.14 patch would've done. I'd go for closing this, but it'd
of course be best if the reporter (Andreas) could try out
http://landfill.bugzilla.org/bugzilla-tip/ and see if the fixes made in the
templatization do what you intended to. As far as I understand the summary and
description of the patch, everything should be ok.
(Reporter)

Comment 7

16 years ago
This bug has not yet been fixed in 2.16.rc1.

A brief visit to landfill turned the following problems:


When I go to Product "FoodReplicator", which allows me to concentrate several 
votes onto a single bug, e.g.,

http://landfill.tequilarista.org/bugzilla-tip/votes.cgi?
action=show_user&bug_id=130

then Bugzilla tells me "To change your votes, type in new numbers (using zero 
to mean no votes) or change the checkbox, and then click Change My Votes."
But there is no checkbox to be seen, so the "or change the checkbox" part is 
confusing and should not show in this case.

If I go to the "WorldControl" project, where I can only give a single vote for 
one bug, e.g.,

http://landfill.tequilarista.org/bugzilla-tip/votes.cgi?
action=show_user&bug_id=271

Bugzilla again tells me "To change your votes, type in new numbers (using zero 
to mean no votes) or change the checkbox, and then click Change My Votes."

In this case, I cannot type in any numbers, so "type in new numbers (using zero 
to mean no votes) or" is confusing and should not show.

When I have already voted for one bug in project "WorldControl" and consider 
voting for a second bug, there should be plural "To change your votes, change 
the checkboxes."

And, of course, there could be a situation when I have votes active in both
projects and a mixed pharse with both "numbers" and "checkboxes" is appropiate.

Comment 8

16 years ago
Ah, excellent. Are you planning to make a patch on this against the current
codebase (templates/en/default/bug/votes/*-stuff)?
(Reporter)

Comment 9

16 years ago
Sorry, no chance.  It's not likely I'll have a chance to touch or look at the 
2.16 codebase anytime soon.

I've done quite a bit of work, customizing Bugzilla 2.14 at our internal site, 
and it works well for us now.  There's little hope the boss here will have or 
let me port all that work to Bugzilla 2.16 - and why should he?  So we're stuck 
with 2.14.

Comment 10

16 years ago
This should be a patch.  This bug can be fixed by making the following changes
to template/en/default/bug/votes/list-for-user.html.tmpl:

 * add

    [% checked_bug = 1 %]

   to the same section as

    <input type="checkbox" name="[% bug.id %]" value="1"
      [% " checked" IF bug.count %]>

   ,

 * add

    [% counted_bug = 1 %]

   to the same section as

    <input name="[% bug.id %]" value="[% bug.count %]" 
      size="2">

   , and

 * change

    To change your votes, type in new numbers (using zero to
    mean no votes) or change the checkbox, and then click 
    <b>Change My Votes</b>.

   to

    To change your votes,
    [% IF counted_bug %]
      type in new numbers (using zero to mean no votes)
      [% IF checked_bug %]
        or
      [% END %]
    [% END %]
    [% IF checked_bug %]
      change the checkbox
    [% END %]
    and then click <b>Change My Votes</b>.

  .

Comment 11

16 years ago
Also, since it talks about changing votes, which is plural, it should probably
also say `change the checkboxes' rather than `change the checkbox'.
Bug 159996 has a patch, which displays either or both of the checkbpox vs number
stuff.

I'm gong to mark it as a dupe of that, for that reason.

*** This bug has been marked as a duplicate of 159996 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
clearing target in DUPLICATE/WORKSFORME/INVALID/WONTFIX bugs so they'll show up
as untriaged if they get reopened.
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.