Closed Bug 1368693 Opened 3 years ago Closed 3 years ago

"./mach eslint" throws "%1 is not a valid Win32 application"

Categories

(Firefox Build System :: Mach Core, enhancement)

53 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1368656

People

(Reporter: Oriol, Unassigned)

Details

"./mach eslint" stopped working on Win10 x64, now it throws

> eslint-plugin-mozilla has out of-date files.
> Installing eslint for mach using "C:\Program Files\nodejs\npm install --loglevel=error"...
> Traceback (most recent call last):
>   File "c:\mozilla-build\mozilla-source\firefox\python/mozlint\mozlint\roller.py", line 56, in _run_worker
>     return _run_linters(*args, **lintargs)
>   File "c:\mozilla-build\mozilla-source\firefox\python/mozlint\mozlint\roller.py", line 43, in _run_linters
>     res = func(paths, linter, **lintargs) or []
>   File "c:\mozilla-build\mozilla-source\firefox\python/mozlint\mozlint\types.py", line 37, in __call__
>     return self._lint(paths, linter, **lintargs)
>   File "c:\mozilla-build\mozilla-source\firefox\python/mozlint\mozlint\types.py", line 104, in _lint
>     return payload(files, **lintargs)
>   File "c:\mozilla-build\mozilla-source\firefox\tools\lint\eslint.lint.py", line 49, in lint
>     setup_helper.eslint_setup()
>   File "c:\mozilla-build\mozilla-source\firefox\tools\lint\eslint\setup_helper.py", line 75, in eslint_setup
>     if not call_process("eslint", cmd):
>   File "c:\mozilla-build\mozilla-source\firefox\tools\lint\eslint\setup_helper.py", line 105, in call_process
>     subprocess.check_call(cmd, cwd=cwd, stdout=fnull)
>   File "c:\mozilla-build\python\lib\subprocess.py", line 535, in check_call
>     retcode = call(*popenargs, **kwargs)
>   File "c:\mozilla-build\python\lib\subprocess.py", line 522, in call
>     return Popen(*popenargs, **kwargs).wait()
>   File "c:\mozilla-build\python\lib\subprocess.py", line 710, in __init__
>     errread, errwrite)
>   File "c:\mozilla-build\python\lib\subprocess.py", line 958, in _execute_child
>     startupinfo)
> WindowsError: [Error 193] %1 is not a valid Win32 application
> Error running mach:
> 
>     ['eslint']
> 
> The error occurred in code that was called by the mach command. This is either
> a bug in the called code itself or in the way that mach is calling it.
> 
> You should consider filing a bug for this issue.
> 
> If filing a bug, please include the full output of mach, including this error
> message.
> 
> The details of the failure are as follows:
> 
> WindowsError: [Error 193] %1 is not a valid Win32 application
> 
>   File "c:\mozilla-build\mozilla-source\firefox\tools/lint/mach_commands.py", line 62, in eslint
>     argv=extra_args, **kwargs)
>   File "c:\mozilla-build\mozilla-source\firefox\python/mach\mach\registrar.py", line 123, in dispatch
>     return self._run_command_handler(handler, context=context, **kwargs)
>   File "c:\mozilla-build\mozilla-source\firefox\python/mach\mach\registrar.py", line 90, in _run_command_handler
>     result = fn(**kwargs)
>   File "c:\mozilla-build\mozilla-source\firefox\tools/lint/mach_commands.py", line 43, in lint
>     return cli.run(*runargs, **lintargs)
>   File "c:\mozilla-build\mozilla-source\firefox\python/mozlint\mozlint\cli.py", line 111, in run
>     workdir=workdir)
>   File "c:\mozilla-build\mozilla-source\firefox\python/mozlint\mozlint\roller.py", line 150, in roll
>     results, failed = worker.get()
>   File "c:\mozilla-build\python\lib\multiprocessing\pool.py", line 567, in get
>     raise self._value

hg bisect says

> The first bad revision is:
> changeset:   361056:5809a30a0c48
> user:        Paolo Amadini <paolo.mozmail@amadzone.org>
> date:        Thu May 25 15:00:49 2017 +0100
> summary:     Bug 1242505 - Part 5 - Remove obsolete whitelisting of unhandled rejections. r=Mossop
Flags: needinfo?(paolo.mozmail)
No longer blocks: 1242505
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(paolo.mozmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1368656
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.