New print - Print to File dialog - Can't tab to File: button

UNCONFIRMED
Unassigned

Status

Thunderbird
Untriaged
UNCONFIRMED
8 months ago
5 months ago

People

(Reporter: Joe Pollock, Unassigned)

Tracking

52 Branch
Unspecified
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.114 Safari/537.36 Vivaldi/1.9.818.50

Steps to reproduce:

Open an email, select Print, select Print to File, try to use tab to get to the File: button


Actual results:

Either never gets there or doesn't show that it does - forced to use mouse to access the button - which then works fine


Expected results:

File: button/field should be in the tabbing order so it can be accessed from the keyboard or at least have a shortcut key. Needed for use with AutoKey (keyboard automation) so I don't have to use image recognition just to get to the button.

This worked perfectly in the previous version of the print dialog.

Comment 1

7 months ago
Did thi salso happen in version 45?
OS: Unspecified → Linux
(Reporter)

Comment 2

7 months ago
Thanks for looking at this.

Not sure of actual version # when it started, but it's only a few months. The print dialog looks different than it did when it worked. That component/dialog was changed and then it immediately stopped working as desired/expected.

I used to be able to select Print to File and then a single tab would get me to the File Name *field*. Now, it appears to be a *button*. It doesn't appear to be in the tabbing order at all. And, since it doesn't have a shortcut key either, it's completely inaccessible from the keyboard. 

This may also be an accessibility issue for those who can't or don't use a mouse.

Comment 3

7 months ago
which linux distro and desktop are you using?
(Reporter)

Comment 4

7 months ago
Sorry. Forgot to include that in the original report.

kubuntu 16.04
KDE Frameworks 5.18.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system

Toshiba notebook  S55 - C5274
Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
(Reporter)

Comment 5

5 months ago
Is this just a dialog you use from a library external to Thunderbird (from KDE, etc.)? If so, I should probably request help from the team responsible for that code.
You need to log in before you can comment on or make changes to this bug.