container crash when browsing bbc website

RESOLVED INCOMPLETE

Status

()

Core
DOM: Security
P1
normal
RESOLVED INCOMPLETE
7 months ago
5 months ago

People

(Reporter: Bhasker C V, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Created attachment 8872881 [details]
crash.txt

User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518070317

Steps to reproduce:

Browse websites under custom container name


Actual results:

1. All tabs opened with the custom container name closed. Other tabs are still present
2. After a few minutes of brwosing,  the custom container name is not available anymore under the new container '+' hover menu.


Expected results:

be able to browse without container crash.

Updated

7 months ago
Component: Untriaged → Security
Product: Firefox → Core
Component: Security → DOM: Security
Marking this as P1 as crashes are obviously never good. I'll investigate see if I can get some STR and a list of platforms that are currently affected.
Blocks: 1191418
QA Whiteboard: [userContextId][domsecurity-backlog1]
Priority: -- → P1
QA Contact: kjozwiak
Kamil, since this is P1, can we find an assignee for this bug? Probably baku?
Flags: needinfo?(kjozwiak)
Have you seen this Baku? I don't think I would be much help with this code at the moment as it's likely a non containerised DOM feature?
Flags: needinfo?(amarchesini)
It doesn't seem we _crash_ but that the container is not available from the '+' menu. Am I wrong?

If we crash, can you submit a crash report? Thanks!
Flags: needinfo?(amarchesini)
(Reporter)

Comment 5

6 months ago
Yes. I agree. The custom container name is no more available from the "+" menu. Almost all container tabs close and I get a blank page tab (non-container tab). Once this "incident"  happens, the custom container name is no more available.
(Reporter)

Comment 6

6 months ago
I upadted the container plugin to 2.3.0 today and I see it is fairly stable. I will update this bug if I still find any issues. Until now ... things are fine.
(In reply to Bhasker C V from comment #6)
> I upadted the container plugin to 2.3.0 today and I see it is fairly stable.
> I will update this bug if I still find any issues. Until now ... things are
> fine.

Bhasker, are you still encountering the problem? If not, I would like to close this bug.
Flags: needinfo?(kjozwiak) → needinfo?(bhasker)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.