make check orange w/ hg unknown command "files"

RESOLVED DUPLICATE of bug 1415803

Status

RESOLVED DUPLICATE of bug 1415803
a year ago
9 months ago

People

(Reporter: ewong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
(cd /builds/slave/c-cen-t-lnx/build/mozilla && /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py);
hg: unknown command 'files'
Traceback (most recent call last):
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py", line 68, in <module>
    main()
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py", line 62, in main
    if not check_files():
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py", line 53, in check_files
    for filename in repo.get_files_in_working_directory():
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 110, in get_files_in_working_directory
    self._run('files', '-0').split('\0'))
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 44, in _run
    env=self._env)
  File "/tools/python27/lib/python2.7/subprocess.py", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '(u'/usr/local/bin/hg', u'files', u'-0')' returned non-zero exit status 255
make[2]: *** [check-js-msg] Error 1
(cd /builds/slave/c-cen-t-lnx/build/mozilla && /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_opcode.py);
TEST-PASS | check_js_opcode.py | ok
make[2]: Target `check' not remade because of errors.
make[2]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/js/src'
make[1]: *** [js/src/check] Error 2
(Reporter)

Comment 1

a year ago
Longer log:

processing /builds/slave/c-cen-t-lnx/build/mozilla/config/tests/src-simple/jar.mn
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/config/tests/src-simple'
Comparing manifests...
Comparing packages...
make[3]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/config/tests/src-simple'
make[2]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/config'
make[2]: Entering directory `/builds/slave/c-cen-t-lnx/build/objdir/js/src'
(cd /builds/slave/c-cen-t-lnx/build/mozilla/js/src && /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/check_spidermonkey_style.py);
hg: unknown command 'files'
Traceback (most recent call last):
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_spidermonkey_style.py", line 597, in <module>
    main()
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_spidermonkey_style.py", line 586, in main
    ok = check_style()
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_spidermonkey_style.py", line 255, in check_style
    for filename in repo.get_files_in_working_directory():
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 110, in get_files_in_working_directory
    self._run('files', '-0').split('\0'))
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 44, in _run
    env=self._env)
  File "/tools/python27/lib/python2.7/subprocess.py", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '(u'/usr/local/bin/hg', u'files', u'-0')' returned non-zero exit status 255
make[2]: *** [check-style] Error 1
(cd /builds/slave/c-cen-t-lnx/build/mozilla/js/src && /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/check_macroassembler_style.py);
hg: unknown command 'files'
Traceback (most recent call last):
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_macroassembler_style.py", line 283, in <module>
    main()
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_macroassembler_style.py", line 272, in main
    ok = check_style()
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_macroassembler_style.py", line 245, in check_style
    for filename in repo.get_files_in_working_directory():
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 110, in get_files_in_working_directory
    self._run('files', '-0').split('\0'))
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 44, in _run
    env=self._env)
  File "/tools/python27/lib/python2.7/subprocess.py", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '(u'/usr/local/bin/hg', u'files', u'-0')' returned non-zero exit status 255
make[2]: *** [check-masm] Error 1
(cd /builds/slave/c-cen-t-lnx/build/mozilla && /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py);
hg: unknown command 'files'
Traceback (most recent call last):
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py", line 68, in <module>
    main()
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py", line 62, in main
    if not check_files():
  File "/builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_msg_encoding.py", line 53, in check_files
    for filename in repo.get_files_in_working_directory():
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 110, in get_files_in_working_directory
    self._run('files', '-0').split('\0'))
  File "/builds/slave/c-cen-t-lnx/build/mozilla/python/mozversioncontrol/mozversioncontrol/__init__.py", line 44, in _run
    env=self._env)
  File "/tools/python27/lib/python2.7/subprocess.py", line 573, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command '(u'/usr/local/bin/hg', u'files', u'-0')' returned non-zero exit status 255
make[2]: *** [check-js-msg] Error 1
(cd /builds/slave/c-cen-t-lnx/build/mozilla && /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/config/check_js_opcode.py);
TEST-PASS | check_js_opcode.py | ok
make[2]: Target `check' not remade because of errors.
make[2]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/js/src'
make[1]: *** [js/src/check] Error 2
make[2]: Entering directory `/builds/slave/c-cen-t-lnx/build/objdir/memory/replace/logalloc/replay'
grep "^1 " /builds/slave/c-cen-t-lnx/build/mozilla/memory/replace/logalloc/replay/replay.log > expected_output.log
MALLOC_LOG=1 LD_PRELOAD=/builds/slave/c-cen-t-lnx/build/objdir/memory/replace/logalloc/replay/../liblogalloc.so ./logalloc-replay < /builds/slave/c-cen-t-lnx/build/mozilla/memory/replace/logalloc/replay/replay.log | sed -n '/jemalloc_stats/,$p' | /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/memory/replace/logalloc/replay/logalloc_munge.py | diff -w - expected_output.log
#0 mapped: 1048576; allocated: 0; waste: 0; dirty: 0; bookkeep: 4096; binunused: 0
#10 mapped: 2097152; allocated: 10336; waste: 0; dirty: 0; bookkeep: 9280; binunused: 66400
rm -f test_output.log
MALLOC_LOG=test_output.log LD_PRELOAD=/builds/slave/c-cen-t-lnx/build/objdir/memory/replace/logalloc/replay/../liblogalloc.so ./logalloc-replay < /builds/slave/c-cen-t-lnx/build/mozilla/memory/replace/logalloc/replay/replay.log
#0 mapped: 1048576; allocated: 0; waste: 0; dirty: 0; bookkeep: 4096; binunused: 0
#10 mapped: 2097152; allocated: 10336; waste: 0; dirty: 0; bookkeep: 9280; binunused: 66400
sed -n '/jemalloc_stats/,$p' test_output.log | /builds/slave/c-cen-t-lnx/build/objdir/_virtualenv/bin/python /builds/slave/c-cen-t-lnx/build/mozilla/memory/replace/logalloc/replay/logalloc_munge.py | diff -w - expected_output.log
make[2]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/memory/replace/logalloc/replay'
make[1]: Target `recurse_check' not remade because of errors.
make[1]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir'
make: *** [check] Error 2
(Reporter)

Comment 2

a year ago
/usr/local/bin/hg is 3.91

Python is 2.7.3  (so I have a hunch that this might be the reason for the orange.
and if this is the case,  bug 1354356 will probably fix this when all builders'
python have been upgraded..)
Isn't this a duplicate of bug 1415803?
Flags: needinfo?(ewong)
(Reporter)

Comment 4

9 months ago
(In reply to Frank-Rainer Grahl (:frg) from comment #3)
> Isn't this a duplicate of bug 1415803?

I believe it is..   *sigh*
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(ewong)
Resolution: --- → DUPLICATE
Duplicate of bug: 1415803
You need to log in before you can comment on or make changes to this bug.