Closed Bug 1368958 Opened 3 years ago Closed 2 years ago

Crash in libxul.so@0x1d00e82 | libxul.so@0x1d295a4 | libxul.so@0x1d28432 | mozilla::CSSStyleSheet::Clone

Categories

(Core :: CSS Parsing and Computation, defect, P3, critical)

Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox57 --- affected

People

(Reporter: Sylvestre, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ecdbc938-b655-44c4-9500-3fd770170531.
=============================================================

Opening a xsls in Google doc. Unfortunately, as this is confidential information, I cannot share the doc to reproduce but this is reproducible.

I can help debugging if needed.

In the term, I see (not sure it is related)

$ Failed to open curl lib from binary, use libcurl.so instead
ExceptionHandler::GenerateDump cloned child 1429
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Failed to open curl lib from binary, use libcurl.so instead
Sandbox: Unexpected EOF, op 0 flags 01101 path /tmp/GeckoChildCrash1373.extra

Backtrace:
 0 	libxul.so	libxul.so@0x1d00e82	
1 	libxul.so	libxul.so@0x1d295a4	
2 	libxul.so	libxul.so@0x1d28432	
3 	libxul.so	mozilla::CSSStyleSheet::Clone	layout/style/CSSStyleSheet.cpp:361
4 	libxul.so	nsIDocument::CreateStaticClone	dom/base/nsDocument.cpp:10095
5 	libxul.so	nsPrintObject::Init	layout/printing/nsPrintObject.cpp:86
6 	libxul.so	nsPrintEngine::DoCommonPrint	layout/printing/nsPrintEngine.cpp:523
7 	libxul.so	nsPrintEngine::CommonPrint	layout/printing/nsPrintEngine.cpp:398
8 	libxul.so	nsPrintEngine::Print	layout/printing/nsPrintEngine.cpp:797
9 	libxul.so	nsDocumentViewer::Print	layout/base/nsDocumentViewer.cpp:3951
10 	libxul.so	nsGlobalWindow::PrintOuter	dom/base/nsGlobalWindow.cpp:8062
11 	libxul.so	mozilla::dom::WindowBinding::print	obj-firefox/dom/bindings/WindowBinding.cpp:2765
12 	libxul.so	mozilla::dom::WindowBinding::genericMethod(JSContext*, unsigned int, JS::Value*)
Sylvestre, since this is reproducible for you, would you mind using mozregression to find where we started crashing on this?
Flags: needinfo?(sledru)
Sure but you know the murphy law right? I cannot reproduce it anymore :(
my other report is bp-91def8fa-bbad-4c76-b730-c2b380170531
Flags: needinfo?(sledru)
Actually, I can reproduce it when trying to print the doc!
It might be related to bug 1339629, which just landed a week ago.
Priority: -- → P3
Sylvestre, is this still reproducible in a recent build?
Flags: needinfo?(sledru)
I don't have the doc anymore and no occurrence of this crash for the last 3 months. We can close it.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(sledru)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.