"Report Site Issue" button shouldn't be enabled on page https://webcompat.com/

RESOLVED INVALID

Status

Web Compatibility Tools
General
RESOLVED INVALID
9 months ago
9 months ago

People

(Reporter: cbadau, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

9 months ago
[Affected versions]:
- latest Nightly 55.0a1 (2017-05-31)

[Affected platforms]:
- Mac OS X 10.12
- Windows 7 x64
- Ubuntu 14.04 x64

[Steps to reproduce]:
1. Launch Firefox and go to a page where the "Report Site Issue" button is enabled. 
2. Click on the "Report Site Issue" button.
3. Go to https://webcompat.com/ page and observe the "Report Site Issue" button.
4. While on https://webcompat.com/ page, click multiple times on the "Report Site Issue" button. 

[Expected result]:
-"Report Site Issue" button is not enabled on page https://webcompat.com/. 

[Actual result]:
- User can report the initial report site issue page. Clicking multiple times on button while user has webcompat in focus website will result in a report loop. Please see the attachment "Report loop.mov".
I'm inclined to WONTFIX this one -- we've never received accidental reports like this. (And we have had people report actual webcompat.com site bugs to us via webcompat.com -- which we close and then open against the GitHub repo).
Blocks: 1306114
Talking with DenSchub, this is expected behavior. Let's mark as INVALID.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.