Crash in mozilla::layers::APZCTreeManager::NotifyScrollbarDragRejected

RESOLVED DUPLICATE of bug 1369074

Status

()

Core
Panning and Zooming
P2
critical
RESOLVED DUPLICATE of bug 1369074
5 months ago
2 months ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression})

55 Branch
Unspecified
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fix-optional)

Details

(Whiteboard: [gfx-noted][clouseau], crash signature)

(Reporter)

Description

5 months ago
This bug was filed from the Socorro interface and is 
report bp-76e1c621-42ea-4da7-9576-98c130170531.
=============================================================

There are 7 crashes in nightly 55 with buildid 20170531100318. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1367837.

[1] https://hg.mozilla.org/mozilla-central/rev?node=db86dd808a1abdeed8459045e055f20236b486c3
Flags: needinfo?(bugmail)
(Reporter)

Updated

5 months ago
Crash Signature: [@ mozilla::layers::APZCTreeManager::NotifyScrollbarDragRejected] → [@ mozilla::layers::APZCTreeManager::NotifyScrollbarDragRejected] [@ mozilla::layers::APZCTreeManager::StartScrollbarDrag ]
It seems unlikely that this would be caused by bug 1367837. More likely one of Botond's scrollbar dragging patches.

From the backtrace it looks like maybe state->mController is nullptr in NotifyScrollbarDragRejected?
Flags: needinfo?(bugmail) → needinfo?(botond)
Component: Graphics: WebRender → Panning and Zooming
Priority: -- → P2
Whiteboard: [clouseau] → [gfx-noted][clouseau]
No longer blocks: 1367837

Comment 2

5 months ago
I posted reliable STR's in bug 1369074
Great, thanks! I'll dupe this over.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1369074
status-firefox55: affected → fix-optional
Blocks: 1396527
You need to log in before you can comment on or make changes to this bug.