bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Support permission unlimitedStorage for chrome.storage

RESOLVED DUPLICATE of bug 1331618

Status

WebExtensions
Compatibility
RESOLVED DUPLICATE of bug 1331618
a year ago
27 days ago

People

(Reporter: Thierry Régagnon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I am working at Dashlane. We are finishing an update to our WebExtension that requires us to store data locally in the browser. We would like to use the chrome.storage.local API for this, as recommended by several browser vendors. 

We are pretty sure to hit the 5 Mo limit. And we need to ask for the "unlimitedStorage" permission. Firefox does not support it while Chrome and Edge do.

If you don't plan to implement it soon, could you recommend an alternative? 
We pondered about using IndexedDB, but it seems that until "unlimitedStorage" is supported we won't be able to persistently store data with it (Bug 1331618).

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331618

Updated

27 days ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.