Social media videos and games stop working when the GPU Process is terminated

RESOLVED DUPLICATE of bug 1369097

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1369097
11 months ago
10 months ago

People

(Reporter: asimonca, Unassigned)

Tracking

({regression})

55 Branch
x86_64
Windows
regression
Points:
---

Firefox Tracking Flags

(firefox55 disabled, firefox56 fixed)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

11 months ago
[Note]:
- This issue only occurs when the "Use hardware acceleration when available" box is ticked.

[Affected versions]:
- Nightly 55.0a1 

[Affected platforms]:
- Windows (7, 8, 10)

[Steps to reproduce]:
Make sure that "layers.gpu-process.enabled" pref is set to true in about:config
1. Open Nightly.
2. Go to Facebook, Twitter or Vimeo.
3. Open a video and make sure it's playing normally.
4. Go to about:support and press the "Terminate GPU Process" button.


[Expected result]:
- The video continues playing even though it experiences a short hang. 

[Actual result]:

On Facebook: The video displays a message saying: "Flash player upgrade required. You must download and install the latest version of Adobe Flash Player to view this content". The video does not work even after a page refresh.

On Twitter: The video displays a message saying: "The media could not be played.". The video does not work even after a page refresh.

On Vimeo: The video goes black but the seek bar continues to play. The video works after a page refresh.

On Facebook Games: The apps stop working altogether. The apps don't work even after a page refresh.
(Reporter)

Updated

11 months ago
status-firefox55: --- → affected
As we switch to software compositor, we end up with a different system, in a way.  It would be interesting to compare the results to those of running without acceleration in the first place.  Especially the "reloading the page doesn't fix it".

There may be multiple bugs in here, so I'll leave it as graphics for now.

Anthony - the "video does not work after a page refresh", can somebody take a look at that?
Flags: needinfo?(ajones)
Keywords: regression
Also, can you (restart not required) set layers.gpu-process.max_restarts to 0 and repeat the workflow and see if the problems are gone or different?
Flags: needinfo?(ajones) → needinfo?(alexandru.simonca)
Whiteboard: [gfx-noted]
(Reporter)

Comment 3

11 months ago
Hi, 
Tested this with the same steps and layers.gpu-process.max_restarts set to 0. I couldn't reproduce the issue anymore and as soon as I switched it back to 3 the issue started popping up again.
Flags: needinfo?(alexandru.simonca)

Updated

11 months ago
Duplicate of this bug: 1368581

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1369097
status-firefox55: affected → disabled
status-firefox56: --- → fixed
You need to log in before you can comment on or make changes to this bug.