After terminating a GPU process youtube videos remain in an infinite loading state

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: ccomorasu, Assigned: domfarolino)

Tracking

({regression})

Trunk
mozilla56
All
Windows
regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 disabled, firefox56+ fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

[Note]:
 - please check that "layers.gpu-process.max_restarts" integer preference is set to "3" (from about:config)
 - please check that the "Use recommended performance settings" checkbox below the "Performance" is checked (from about:preferences -> General)

[Affected versions]:
 Fx 55.0a1

[Affected platforms]:
 Windows 8.1 x32
 Windows 7 x64

[Steps to reproduce]:
 1. Launch Firefox.
 2. Go to a youtube video.
 3. Terminate the CPU process from about:support .


[Expected result]:
 A short glitch, afterwords the video plays smoothly.

[Actual result]:
 The video remains in an infinite loading state.

[Regression range]:
 Will return with the regression range as soon as possible.

[Additional notes]:
 A gif with the issue: http://imgur.com/a/CQR6A .
Summary: After terminating a CPU process youtube videos remain in an infinite loading state → After terminating a GPU process youtube videos remain in an infinite loading state
It'd be also good to know if pause/play or reloading the page fixes the problem.
Keywords: regression
Also, can you (restart not required) set layers.gpu-process.max_restarts to 0 and repeat the workflow and see if the problems are gone or different?
Flags: needinfo?(cristian.comorasu)
Whiteboard: [gfx-noted]
I tested with the pref "layers.gpu-process.max_restarts" to "0" using Fx 55.0a1, build ID: 20170605030204, on Windows 10 x64, Windows 8.1 x32 and Windows 7 x64.
This issue is not reproducible under these circumstances.

Cheers!
Flags: needinfo?(cristian.comorasu)
David, let's reset this preference back to the default (I never know if that's 0 or 1), so that we never restart to accelerated beyond nightly.  It'll give us a chance to sort out the issues, but it'll stay on nightly until we're sure we're good and sort out the telemetry/etc. we need for making the right call.

[Tracking Requested - why for this release]: This should block 55 - we don't want a preference where we have some negative anecdotal, and no telemetry/crash evidence to tell us otherwise.
Assignee: nobody → domfarolino
tracking-firefox56: --- → ?
Flags: needinfo?(dvander)
Sounds good. I'll file a new bug so we can track this issue separately.
Flags: needinfo?(dvander)
This functionality will be off in 55, so no need to track it for 55.
status-firefox55: affected → unaffected

Comment 8

2 years ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b6314a490ce8
Only restart the GPU process multiple times on Nightly. (bug 1369097, r=milan)

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b6314a490ce8
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
tracking-firefox56: ? → +
status-firefox54: --- → unaffected
status-firefox55: unaffected → disabled
status-firefox-esr52: --- → unaffected
Looks like bug 1388309 is the same with this one?
See Also: → bug 1388309
Flags: qe-verify+
Created attachment 8906647 [details]
21682710_262557600930285_2027079936_o.png

Hi,
This issue doesn't seem fixed to me. The actual result is different now but the steps for getting there are the same. 
If the GPU process is terminated while a YouTube video is playing an error message appears and not even a refresh can make it work. A browser restart is needed for watching the clip again. 
This only happens on 32 bit builds of Firefox.
Tested on: 
- Windows 7 x86 & x64
- Windows 8.1 x64
- Windows 10 x64

Please see the attachment for the error.
Dominic, did you get the chance to look at Comment 11?
Flags: needinfo?(domfarolino)
Dominic's internship ended in August, taking needinfo
Flags: needinfo?(domfarolino) → needinfo?(dvander)
You need to log in before you can comment on or make changes to this bug.