Closed Bug 1369183 Opened 3 years ago Closed 3 years ago

NVDA/JAWS Screenreader does not read output from combobox when e10s is enabled

Categories

(Core :: Disability Access APIs, defect, P2)

55 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: u554753, Unassigned)

References

(Blocks 1 open bug, )

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
JAWS Version: 18.0.2945

Steps to Reproduce:
1. Go to https://bugzilla.mozilla.org/page.cgi?id=productdashboard.html
2. Focus the combo box
3. Use the arrow keys to scroll up and down and make selections.

Expected Result:
The different choices are highlighted and the JAWS screenreader reads the choice

Actual Result:
The browser hangs and/or the JAWS screenreader does not read out the selection.


This happens only when e10s is enabled. It functions normally when e10s is disabled.
This is also reproducible with the NVDA screenreader.

Version 2017.2
Summary: JAWS Screenreader does not read output from combobox when e10s is enabled → NVDA/JAWS Screenreader does not read output from combobox when e10s is enabled
This issue is still reproducible with the below specs. Furthermore, it no longer opens combobox or list choices when navigated with the arrow keys.

Firefox Nightly - 57.0a1 
JAWS Version - 18.0.4938
Priority: -- → P2
needs confirmation that this still happens in nvda.
Flags: needinfo?(mzehe)
I cannot reproduce. There is a lag between hitting DownArrow and the response, but this is due to the dynamic nature of the beast. It can take up to two seconds for speech to speak the new value, which is how long it appears to need to update other fields on the page with the new content. WFM in NVDA.
Flags: needinfo?(mzehe)
And I can also confirm that JAWS reads a selection change in that combobox at least once. After that, it completely messes up, loses contact to the web content, its virtual buffer goes blank, and it freezes Firefox. But I have seen that kind of thing elsewhere, so this is a bigger underlying problem. Jim, you should be able to repro this with Grover's steps. Load your Bugzilla dashboard, focus the combo box, make sure you enter into forms mode (high-pitch plop), and then press DownArrow. First one will most likely succeed (it did for me), and then subsequent arrow presses won't yield any speech. JAWS will continue to work, but Firefox will be frozen.
Flags: needinfo?(jmathies)
(In reply to Grover Wimberly IV [:Grover-QA] from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101
> Firefox/55.0
> JAWS Version: 18.0.2945
> 
> Steps to Reproduce:
> 1. Go to https://bugzilla.mozilla.org/page.cgi?id=productdashboard.html
> 2. Focus the combo box
> 3. Use the arrow keys to scroll up and down and make selections.

This page is down, will any combo box work? For example, can you repo on this test case?

http://mathies.com/mozilla/twoformselects.html
Flags: needinfo?(jmathies) → needinfo?(gwimberly)
(In reply to Jim Mathies [:jimm] from comment #6)
> This page is down, will any combo box work? For example, can you repo on
> this test case?
> 
> http://mathies.com/mozilla/twoformselects.html

Works as intended on NVDA, test case reproducible with JAWS.0.4238.
Flags: needinfo?(gwimberly)
I can't repo this with our current testing build of JAWS. STR:

1) open http://mathies.com/mozilla/twoformselects.html
2) tab until the first select is focused
3) press enter (high pitched bloop)
4) use up and down arrows to navigate the select. each item is narrated properly.

Grover, can you please compare your test steps to steps above and let me know if there are differences? Trying to figure out what we're not getting the same results.
(In reply to Jim Mathies [:jimm] from comment #8)
> I can't repo this with our current testing build of JAWS. STR:
> 
> 1) open http://mathies.com/mozilla/twoformselects.html
> 2) tab until the first select is focused
> 3) press enter (high pitched bloop)
> 4) use up and down arrows to navigate the select. each item is narrated
> properly.
> 
> Grover, can you please compare your test steps to steps above and let me
> know if there are differences? Trying to figure out what we're not getting
> the same results.

An easy way to reproduce this is on the left combo box, press the arrow for the drop down window twice. This expands and then recollapses the combo box and puts it in focus. From there, press the up and down arrow keys. NVDA reads those choices out loud. JAWS does not.
Flags: needinfo?(jmathies)
per Grover testing.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.