Robosizer causes crash during startup

RESOLVED FIXED

Status

()

RESOLVED FIXED
a year ago
3 months ago

People

(Reporter: ccorcoran, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

50.37 KB, application/octet-stream
Details
(Reporter)

Description

a year ago
Created attachment 8873195 [details]
minidumps.zip

Steps to repro:
Windows 10 enterprise x64

1. Install Firefox 64-bit (in my case, Nightly buildID 20170530030204)
2. Install Robosizer from bug 1322554 comment 40
3. Launch Firefox

100% repro crash on startup, sometimes before crash reporter is engaged. Minidump + extra attached. Appears to be caused by EasyHook64.dll which hooks a number of APIs resulting in corruption on a random thread.

Updated

a year ago
See Also: → bug 1335080
Is this fixed now that the BaseThreadInitThunk work is enabled for both 32 and 64 bit?
Flags: needinfo?(ccorcoran)
(Reporter)

Comment 2

3 months ago
Verified fixed in 63.0a1 64-bit
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(ccorcoran)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.