Getting decode error when during playback of media using MSE

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
7 months ago
6 months ago

People

(Reporter: Kamal, Assigned: jya)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

http://stormfly.adobe.com/static/external_bugs/firefox_bug/sample.html

Navigate to the above link in Firefox version 50.0.3 (64 bit).
This will load a sample app which download two MP4 segments and play them using MSE APIs.


Actual results:

When playing second segment following error is seen in console:

"Media resource blob:http://stormfly.adobe.com/6c4e3a19-3238-6d47-bffd-0cf2163800e0 could not be decoded." and playback is terminated.


Expected results:

Playback of both segments should be successful. Playback works fine on other browsers like Chrome.
(Reporter)

Comment 1

7 months ago
This issue is seen on MAC OSX 10.11 and 10.12.
(Assignee)

Updated

7 months ago
Assignee: nobody → jyavenard
(Assignee)

Comment 2

6 months ago
I'm unable to reproduce as the server doesn't respond.

Any chance you could attach a zip of it here?

thank you
Flags: needinfo?(kgulati)
(Reporter)

Comment 3

6 months ago
Please try with this link. It should be responding.
http://de9b7h88wgj5l.cloudfront.net/static/external_bugs/firefox_bug/sample.html
Flags: needinfo?(kgulati)
(Assignee)

Comment 4

6 months ago
For whatever reason, Apple VideoToolBox error on the content and silently drop the frames. Only the first initial frame can be decoded

Apple Quicktime is also unable to play this content (The document “fileSequence0.mp4” could not be opened. An unknown error occurred (-12842)) which is the same error code Apple VT returns.
As only the first frame can be decoded, the Finder can show it.
Safari also fails to play it (and behaves weirdly with the audio track)

FFmpeg shows an error in decoding the slice header, but can step over:
[h264 @ 0x7ff82c863200] Frame num change from 1 to 2
[h264 @ 0x7ff82c863200] decode_slice_header error

Chrome uses libavcodec to play this content, which is why it plays it.

I'm afraid there's nothing much we can do here...
I guess we should be able to display that first frame.
What's happening here is that the decoder returns the first frame but it's kept in the queue to ensure it's properly reordered per the pts.
The 2nd frame decoding errors and is passed to the media element. As we allow some leeway in error we attempt one more time, so we skip to the next keyframe, can decode that one, but fail once again on the 2nd frame.

You should report the bug to Apple directly. They may look further on what's wrong with this content.

Marking as won't fix as the problem is upstream and outside our ability to correct it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.