Style editor is missing multiple style sheets

RESOLVED INVALID

Status

DevTools
Style Editor
RESOLVED INVALID
a year ago
6 days ago

People

(Reporter: phaiz, Unassigned)

Tracking

53 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

F12 - Style Editor


Actual results:

Several style sheets, including my custom.css files on two different pages are not being displayed. I've confirmed that both files still exist on the server.


Expected results:

My files should have been displayed

Updated

a year ago
Component: Untriaged → Developer Tools: Style Editor
(Reporter)

Comment 1

a year ago
Update:

Seems to be a file permission issue that never was a problem before. I changed ownership of my custom css files from www-data to myself and after changing their ownership back to www-data everything is being displayed in the style editor once again.

Could this be a settings issue? Is there something preventing files from being displayed if they have a different owner?

Comment 2

a year ago
Do you have a testcase/website we could try this on?
(Reporter)

Comment 3

a year ago
(In reply to Tim Nguyen :ntim from comment #2)
> Do you have a testcase/website we could try this on?

After seeing the same problem with other browsers I did some more digging. I believe it was an issue with a template plugin that I have since disabled, and not related to FF, as file ownership is no longer causing these files to not be shown.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Updated

6 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.