Change NS_STYLE_WHITESPACE macro definitions to enum class

RESOLVED FIXED in Firefox 55

Status

()

defect
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: jeff.hajewski, Assigned: jeff.hajewski)

Tracking

54 Branch
mozilla55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170529025116

Steps to reproduce:

Nothing to reproduce - this is a patch for bug 1277133


Actual results:

Currently using NS_STYLE_WHITESPACE* macro definitions


Expected results:

Want to change this to class enum StyleWhiteSpace::*
Assignee

Updated

2 years ago
Attachment #8873525 - Attachment is obsolete: true
Assignee

Updated

2 years ago
Attachment #8873526 - Flags: review?(manishearth)
Component: Untriaged → DOM
Product: Firefox → Core
Assignee: nobody → jeff.hajewski
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8873526 - Flags: review?(manishearth) → review+
This looks good. There are some stylo bits that will need to be done for this to land, I'll handle those for you.
Assignee

Comment 4

2 years ago
(In reply to Manish Goregaokar [:manishearth] from comment #3)
> This looks good. There are some stylo bits that will need to be done for
> this to land, I'll handle those for you.

Thanks Manish - if you would like me to help in any way please let me know, otherwise I'll review your changes to see what I should do next time. Also, for my future reference, are there any style scripts that can catch the style errors?

Lastly, should the constants in servo be updated as well?
Oh, actually, there's a mistake here, `NoWrap` should be `Nowrap`, since it's a single unhyphenated keyword.

The stylo side changes need a tricky setup to do, and will be automatic eventually. Ignore those.

(The servo-side constants is what I mean by "stylo changes")
Assignee

Comment 6

2 years ago
(In reply to Manish Goregaokar [:manishearth] from comment #5)
> Oh, actually, there's a mistake here, `NoWrap` should be `Nowrap`, since
> it's a single unhyphenated keyword.
> 
> The stylo side changes need a tricky setup to do, and will be automatic
> eventually. Ignore those.
> 
> (The servo-side constants is what I mean by "stylo changes")

Great catch Manish. How should I handle these changes? Should I attach a second patch that makes the correction or rebase my prior patch?
Amend the prior patch, mark the uploaded one as obsolete, and attach a new patch.

Once you have try access you'll be able to use Mozreview which is easier.
Assignee

Updated

2 years ago
Attachment #8873526 - Attachment is obsolete: true
Assignee

Updated

2 years ago
Attachment #8873562 - Flags: review?(manishearth)
Attachment #8873562 - Flags: review?(manishearth) → review+
Servo side rolled into https://github.com/servo/servo/pull/17121 (didn't want to make another pull request)

Comment 10

2 years ago
Pushed by manishearth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e8e908b731ad
Change NS_STYLE_WHITESPACE macro definitions to enum class; r=manishearth

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e8e908b731ad
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.