Closed Bug 1369499 Opened 5 years ago Closed 3 years ago

about:logins > Edit login does not persist changes on Android

Categories

(Firefox for Android Graveyard :: Logins, Passwords and Form Fill, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: nalexander, Unassigned)

References

Details

To reproduce:

1. Install Fennec.
2. Navigate to `youtube.com`.
3. Sign in.
4. Choose "Remember password" in dropdown.
5. Tap kebab menu > Tools > Logins.
6. Witness error message in |adb logcat|:

GeckoConsole  E  [JavaScript Error: "_getLoginDataFromParent: A form origin is required" {file: "resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js" line: 925}]

7. Tap login, select Edit login.
8. Edit data -- I appended 2 to the site and the email address.
9. Tap Update.
10. Witness "Saved login" toast and return to Logins portion of page.
11. Witness error message in |adb logcat|:

GeckoConsole  E  [JavaScript Error: "TypeError: null is not a valid URL." {file: "resource://gre/modules/LoginManagerParent.jsm" line: 101}]

What is happening is that LoginUtils._getPasswordOrigin [0] is failing for about:logins (which is Android-only).  I gather these failures then prevent other things happening, although I don't understand how or why.

Tested against Beta [1] and Nightly [2].

[0] http://searchfox.org/mozilla-central/rev/1a0d9545b9805f50a70de703a3c04fc0d22e3839/toolkit/components/passwordmgr/LoginManagerContent.jsm#1381
[1] http://archive.mozilla.org/pub/mobile/releases/54.0b8/android-api-15/multi/fennec-54.0b8.multi.android-arm.apk
[2] http://archive.mozilla.org/pub/mobile/nightly/2017/06/2017-06-01-10-02-05-mozilla-central-android-api-15/fennec-55.0a1.multi.android-arm.apk
MattN: I filed this on the Android side of the house, but I think it's really an incorrect assumption in the LoginManager.  Can you triage?

This has probably been broken for years, since the last relevant activity in that code base is either 2015 or 2016.  I wonder if we have telemetry on the use of about:logins (and in particular Edit login) in Firefox for Android, and whether we should remove this feature entirely.  (We definitely don't test about:logins thoroughly.)
Flags: needinfo?(MattN+bmo)
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5

At least as of now, I still see the errors but the login is updated fine.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.