Downloads with *.ova file extension are renamed to *.ovf

RESOLVED WORKSFORME

Status

()

defect
P5
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: JasonJAyalaP, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

Download a .ova file such as:
https://download.whonix.org/linux/14.0.0.2.6/Whonix-Gateway-14.0.0.2.6.ova

I am on macOS Sierra running latest stable.


Actual results:

Extension is immediately renamed to .ovf (first with .part, then .ovf after finished).


Expected results:

File extension should not be renamed to a related but incompatible file extension. How this happened is beyond me. Too similar to be a coincidence, yet very weird. Chrome and Safari on mac do not have this problem.
Component: Untriaged → Downloads API
Product: Firefox → Toolkit

Comment 1

2 years ago
WFM with FF53 on Win 7. I think it's related to the file association on your OS.

Comment 2

2 years ago
This may happen if the server sends a Content-Type header that is locally associated to "ovf" but does not have "ova" as an additional valid extension for the same MIME type.

Can you try to locate the "mimeTypes.rdf" file in your Firefox profile folder, rename it to something else while Firefox is not running, then see if the problem still occurs?
Component: Downloads API → File Handling
Flags: needinfo?(JasonJAyalaP)
Priority: -- → P5
Product: Toolkit → Firefox
Reporter

Comment 3

2 years ago
Since upgrading to FF54, the problem went away.
Flags: needinfo?(JasonJAyalaP)

Comment 4

2 years ago
Thank you for letting us know!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.