Top Sites doesn't show history entries that result in redirects

RESOLVED INVALID

Status

()

Firefox for Android
Awesomescreen
RESOLVED INVALID
6 months ago
4 months ago

People

(Reporter: Paul, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170509205512

Steps to reproduce:

Firefox for Android 55.0a1 (2017-06-01)

Open the Awesomescreen. Make sure you have visited a page that result in a redirect, e.g. https://en.wikipedia.org/wiki/ (useful for entering the required Wikipedia article URL directly), enough times that it should appear as a Top Site.


Actual results:

Pages like https://en.wikipedia.org/wiki/ do not appear in Top Sites since yesterday's Highlights change, even if they are the most popular pages in history, and even if they exist as bookmarks.


Expected results:

Top Sites should show the most visited pages in the browser's history. Maybe Highlights should show them too/instead, but it doesn't.

A temporary workaround is to take a page that exists as a Highlight, bookmark it, and then edit the bookmark accordingly. However, it will stay in Highlights only until it is clicked once or twice.
(Reporter)

Comment 1

4 months ago
Resolved in 56.0a1 Nightly as of a couple weeks ago. These pages now appear in Top Sites as "user-ent..." (presumably user entered), and since a few days ago, also work correctly when tapped.

Ideally they would show a more accurate name and icon, but this will do.

Please close as FIXED.

Comment 2

4 months ago
Based on Paul's comment, this bug will be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.