The lock and header url in the site identity subview are not on the same line

VERIFIED FIXED in Firefox 55

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: johannh, Assigned: mikedeboer)

Tracking

({regression})

unspecified
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

Attachments

(1 attachment)

Reporter

Updated

2 years ago
Priority: -- → P1
Assignee

Comment 1

2 years ago
Gijs, why was the change from

`panelview:not([title]) > .panel-header` to `panelview[mainView] > .panel-header` necessary again? This rule change in browser.css causes the header to be shown in all panelmultiviews, not just the photon one. :(
Blocks: 1354155
Flags: needinfo?(gijskruitbosch+bugs)

Comment 3

2 years ago
(In reply to Mike de Boer [:mikedeboer] from comment #1)
> Gijs, why was the change from
> 
> `panelview:not([title]) > .panel-header` to `panelview[mainView] >
> .panel-header` necessary again? This rule change in browser.css causes the
> header to be shown in all panelmultiviews, not just the photon one. :(

Because otherwise the title is visible when a view with a title (such as the library view) is displayed as a main view (ie when displayed using the library button in the toolbar).
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8873766 [details]
Bug 1369659 - Make sure to hide the panelview header in non-photon panels, because it breaks their layout.

https://reviewboard.mozilla.org/r/145178/#review149146

Tentative r=me... can we also fix this by re-adding a :not([title]) selector in addition to the panelview[mainview] one (checking carefully that the library panel still works correctly when first opened as a subview in the main photon panel (which will cause the title attribute to get set based on its anchor there), and then as a 'standalone' panel)? If so, I would prefer that, because I imagine we want to eventually switch all the panelmultiviews to photon ones, and then get rid of the 'photon' in the name, at which point we'd have to fix this again...
Attachment #8873766 - Flags: review?(gijskruitbosch+bugs) → review+
Comment hidden (mozreview-request)

Comment 6

2 years ago
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb5fc68d7f71
Make sure to hide the panelview header in non-photon panels, because it breaks their layout. r=Gijs

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bb5fc68d7f71
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.