Closed Bug 1369682 Opened 2 years ago Closed 2 years ago

4.17% damp (linux64) regression on push 12783b5a0fca4162a36a61b45f7b2a5bc2b452d1 (Thu Jun 1 2017)

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1338493

People

(Reporter: igoldan, Assigned: schien)

References

Details

(Keywords: perf, regression, talos-regression, Whiteboard: [necko-active])

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=12783b5a0fca4162a36a61b45f7b2a5bc2b452d1

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  damp summary linux64 opt e10s     288.69 -> 300.73


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=6995

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → Networking
Product: Firefox → Core
This regression minorly reproduces on windows10 platform. Tests there helped me narrow down the origin to two bugs: Bug 1015466 and Bug 1366932.

Could you state and confirm which of these is more related to this issue?
Flags: needinfo?(xeonchen)
Flags: needinfo?(schien)
The patch in bug 1366932 is quite simple, it just read a integer value from preference, and the default value is not changing the following behavior, so I think it's really not highly related to bug 1366932.

If you need more information, just ni? me anytime. I'm glad to do more investigation.
Flags: needinfo?(xeonchen)
Might be the same reason as bug 1369632, if damp also includes page loading time in the metric. keep ni before the root cause is confirmed.
Assignee: nobody → schien
Whiteboard: [necko-active]
Based on Bug 1338493 comment #22, this regression is resolved as we move the IPC message handler further off main thread.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(schien)
Resolution: --- → DUPLICATE
Duplicate of bug: 1338493
You need to log in before you can comment on or make changes to this bug.