Closed Bug 1369708 Opened 2 years ago Closed 2 years ago

Bump mozrunner and mozprofile for geckodriver to avoid default preferences set by mozrunner

Categories

(Testing :: geckodriver, defect)

Version 3
defect
Not set

Tracking

(firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

Attachments

(1 file)

Mozrunner is setting default preferences for the application's profile which are related to automated tests. Instead of doing it at this level the test harnesses have to do it.

Bad side-effect for the moment is that the same preferences set via the firefox options capability are not honored.

For details see:

https://github.com/jgraham/rust_mozrunner/pull/8
https://github.com/jgraham/rust_mozprofile/pull/6
Comment on attachment 8873816 [details]
Bug 1369708 - Avoid setting of default preferences by mozrunner.

https://reviewboard.mozilla.org/r/145246/#review149222

This looks good, but in the future it would be good if you could update the dependencies in a separate commit.  This makes sense logically and makes it easier for the reviewer to know what to look at.

Also, I don’t see a try run associated with this?
Attachment #8873816 - Flags: review?(ato) → review+
(In reply to Andreas Tolfsen ‹:ato› from comment #2)
> This looks good, but in the future it would be good if you could update the
> dependencies in a separate commit.  This makes sense logically and makes it
> easier for the reviewer to know what to look at.

Not sure what you mean. This is a version bump commit only. No other changes have been made to geckodriver.
Try looks fine. I will try to land but it might not work due to the landing of bug 1364385 a couple of minutes ago.
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s effba04f6768 -d b055ba326f1f: rebasing 399878:effba04f6768 "Bug 1369708 - Avoid setting of default preferences by mozrunner. r=ato" (tip)
merging testing/geckodriver/Cargo.lock
warning: conflicts while merging testing/geckodriver/Cargo.lock! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Component: Marionette → geckodriver
Whiteboard: [geckodriver]
(In reply to Henrik Skupin (:whimboo) from comment #3)
> (In reply to Andreas Tolfsen ‹:ato› from comment #2)
> > This looks good, but in the future it would be good if you could update the
> > dependencies in a separate commit.  This makes sense logically and makes it
> > easier for the reviewer to know what to look at.
> 
> Not sure what you mean. This is a version bump commit only. No other changes
> have been made to geckodriver.

I meant it would be good if you had one commit changing the version number
in testing/geckodriver/Cargo.toml and any possible API updated, and one commit
with the changes after running `./mach vendor rust` updating third_party/rust.
(In reply to Andreas Tolfsen ‹:ato› from comment #6)
> I meant it would be good if you had one commit changing the version number
> in testing/geckodriver/Cargo.toml and any possible API updated, and one
> commit
> with the changes after running `./mach vendor rust` updating
> third_party/rust.

This would add an incompatible commit to the version history, which I don't see useful for regression testing. The new versions as vendored in are tidily related to the code changes in geckdriver.
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4eff5f82fe40
Avoid setting of default preferences by mozrunner. r=ato
https://hg.mozilla.org/mozilla-central/rev/4eff5f82fe40
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.