Solaris gcc build of xptcall wrongly expects xptcstubsdef_asm.solx86

RESOLVED FIXED in Firefox 56

Status

()

Core
Build Config
RESOLVED FIXED
8 months ago
7 months ago

People

(Reporter: Petr Sumbera, Assigned: Petr Sumbera)

Tracking

Trunk
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

127:16.87 xpcshell
127:24.74 gmake[5]: *** No rule to make target 'xptcstubsdef_asm.solx86', needed by 'misc'.  Stop.
127:24.74 gmake[4]: *** [/var/tmp/firefox/config/recurse.mk:100: xpcom/reflect/xptcall/md/unix/misc] Error 2

xptcstubsdef_asm.solx86 is generated just when gcc is not used
(Assignee)

Comment 1

8 months ago
Created attachment 8873819 [details] [diff] [review]
Bug1369713.patch
Attachment #8873819 - Flags: review?(mh+mozilla)

Updated

8 months ago
Component: Untriaged → Build Config
Product: Firefox → Core
Comment on attachment 8873819 [details] [diff] [review]
Bug1369713.patch

Review of attachment 8873819 [details] [diff] [review]:
-----------------------------------------------------------------

::: xpcom/reflect/xptcall/md/unix/moz.build
@@ +59,5 @@
>                  'xptcinvoke_x86_64_unix.cpp',
>                  'xptcstubs_x86_64_linux.cpp'
>              ]
>          else:
> +            GENERATED_FILES = [

You might as well remove the parts that are not GNU_CC, since we don't support building with something other than GCC/Clang on Solaris (CONFIG['GNU_CC'] is true for clang too)
Attachment #8873819 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 3

7 months ago
I would prefer not to remove it now. I would have to remove also those unused files then. And it's not so long after we tried to use Studio compiler.
(Assignee)

Updated

7 months ago
Keywords: checkin-needed
Assignee: nobody → petr.sumbera

Comment 4

7 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c16110ecba6
Solaris gcc build of xptcall wrongly expects xptcstubsdef_asm.solx86. r=glandium
Keywords: checkin-needed

Comment 5

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0c16110ecba6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.