Closed Bug 1369772 Opened 2 years ago Closed 2 years ago

Crash in mozilla::gfx::VRLayerChild::SubmitFrame

Categories

(Core :: Graphics: Layers, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: jseward, Assigned: kip)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-18482b59-7a8a-452c-a077-dd7760170601.
=============================================================

This is topcrash #8 in the Windows nightly of 20170601030206.
In fact there are only 2 different installations, but the stack looks
like it might be something specific and actionable; filing therefore.
Flags: needinfo?(dmu)
Blocks: 1362213
This seems to be a regression from Bug 1362213. I will ask if kip has deal about it. Or, I will take a look next week.
Flags: needinfo?(dmu)
I am investigating now
Assignee: nobody → kgilbert
These crash reports all share the same logged error:

|[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=240.713) 

I suspect that this may be due to failure to recover when a WebVR site is presenting to the headset and the GPU process is killed.

One case of the GPU process being killed has been confirmed by Oculus, whose software update mechanism kindly asks applications to unload their library but then falls back to closing any processes holding their files so they can be updated.

For the Oculus case, that will be fixed by the patch landing in Bug 1287944.

It would also be worthwhile to correct any issues that cause the browser to crash when the GPU is killed for other reasons.
After some experimentation, it appears that the content process is not crashing on SubmitFrame() when killing the GPU process.  The page continues to function until attempting to exit VR presentation or close the page.  When this happens the call stack matches that in Bug 1321275.
This crash stack hasn't occurred in 3 months, and the content process no longer crashes when the GPU process is terminated.  I think we can close this one.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.