If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Save password window has the buttons in a wrong order

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
4 months ago
4 months ago

People

(Reporter: Towkir, Unassigned)

Tracking

Trunk
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Created attachment 8874004 [details]
save-password-window-buttons.png

This is a linux only bug (I did not find it on windows)

STR:
1. Open facebook.com / or anyother website that requires login.
2. Enter your login info.
   and there will be a window asking your permission to save your password.
3. Notice the buttons.

Expectation:
The buttons should be in an order like:

+--------+--------------+----+
|  Save  |  Don't Save  | ▼  |
+--------+--------------+----+

Actual Results:
The buttons are organized like this:

+-------------+-----+--------+
| Don't Save  |  ▼  |  Save  |
+-------------+-----+--------+

[See attached screenshot to understand the issue]
This is intended, on Windows confirm buttons are on the left, while OSX (and our default convention) puts them to the right.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 months ago
Does it look good to leave a dropmarker at the middle of two buttons while it's a separate button.
How about this ?

+-------------+--------+-----+
| Don't Save  |  Save  |  ▼  |
+-------------+--------+-----+

or :

+-----+-------------+--------+
|  ▼  | Don't Save  |  Save  |
+-----+-------------+--------+

I will leave that up-to the UX team.
Flags: needinfo?(jhofmann)
Keywords: uiwanted
(In reply to [:Towkir] Ahmed from comment #2)
> Does it look good to leave a dropmarker at the middle of two buttons while
> it's a separate button.

It's not really a separate button. It's meant as an extension of the main secondary action. Dropmarkers are a common pattern.

> How about this ?
> 
> +-------------+--------+-----+
> | Don't Save  |  Save  |  ▼  |
> +-------------+--------+-----+
 
That doesn't work because the dropmarker context is supposed to be with the left button, not the right.

> or :
> 
> +-----+-------------+--------+
> |  ▼  | Don't Save  |  Save  |
> +-----+-------------+--------+

Dropdowns have traditionally been on the right hand side, I think putting it to the left is rather confusing.

> I will leave that up-to the UX team.

This was designed by the UX team, you can find the spec here: https://mozilla.invisionapp.com/share/PC3Y0QSRK#/screens/96290118
Flags: needinfo?(jhofmann)
(Reporter)

Comment 4

4 months ago
I thought the dropmarker was a child of the whole container, but seems like it is treated as a part of the "Don't Save" button.
In that case, it is legit.
Thanks for the resources and explanations Hofmann.
Keywords: uiwanted
You need to log in before you can comment on or make changes to this bug.