Videos on Twitter fail to play and show an error screen after loading

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
11 months ago
11 months ago

People

(Reporter: Josh Tumath, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170602030204

Steps to reproduce:

Find a video on Twitter.


Actual results:

The video shows the error message 'The media could not be played.'

The following messages appear in my Web console:

00:27:48.435 Content Security Policy: Directive ‘frame-src’ has been deprecated. Please use directive ‘child-src’ instead.
00:27:50.388 Content Security Policy: Directive ‘frame-src’ has been deprecated. Please use directive ‘child-src’ instead.
00:27:50.718 Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src https://twitter.com http://localhost:* http://localhost.twitter.com:* https://*.twitter.com https://*.twimg.com https://vine.co https://*.vine.co https://*.periscope.tv https://*.pscp.tv”). Source: onfocusin attribute on DIV element.
870579996292763650
00:27:50.853 HTTP load failed with status 404. Load of media resource https://video.twimg.com/tweet_video/DBTruj_WsAAp_IH.mp4 failed.

Comment 1

11 months ago
Could you share the link of the tweet with the video, please.
That said, https://video.twimg.com/tweet_video/DBTruj_WsAAp_IH.mp4 works for me in Nightly on Win 7.
Flags: needinfo?(josh.tumath+bugzilla)
(Reporter)

Comment 2

11 months ago
(In reply to Loic from comment #1)
> Could you share the link of the tweet with the video, please.
> That said, https://video.twimg.com/tweet_video/DBTruj_WsAAp_IH.mp4 works for
> me in Nightly on Win 7.

It looks as though whatever was causing this bug has been fixed in today's Nightly release. I'll reopen this if I can reproduce it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(josh.tumath+bugzilla)
Resolution: --- → WORKSFORME
The error was 404. It's a twitter issue, nothing to do with firefox.
You need to log in before you can comment on or make changes to this bug.