Closed Bug 1369947 Opened 4 years ago Closed 4 years ago

Remember state when the Box Model pane is closed (in the Layout Panel)

Categories

(DevTools :: Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1359763

People

(Reporter: jensimmons, Unassigned)

References

Details

Anytime you click on the Layout Panel, the Box Model pane is there, hogging up all the room.

https://monosnap.com/file/RJhne55wXccpTaEDupH4NNoPFfbkuY.png

I can click on that title bar, and close the Box Model pane, to get it out of the way and give me space for the Grid pane (and later the Flexbox pane, etc).

https://monosnap.com/file/lEwtB134ORjGSfMaseZagOhO1yiVBj.png

The only thing is, I have to do this every. single. time. 

Which is annoying. Some people really like the Box Model pane and use it frequently. Many people do not. My theory is that if you are working on a project where the designers think "pixel perfect" is a thing, and have specified their design in PDFs using pixels, then the Box Model tools are helpful. If you are working with a modern designer who understands Responsive Web Design, then there's no such thing as "pixel perfect", and this tool is not nearly as useful. 

It would be great if the state of open or closed would be remembered by the browser. And those of us who never use the Box model Pane don't have to keep dismissing it every time we open a new web page. 

It'd be even more awesome if there were a way to rearrange the order of the panes, and put your favorite one at the top. I'd drag "Grid" above "Box Model" and never look back. Then, once there's a Flexbox pane, and a Shapes pane, and a Alignment pane, I could put the panes in the order that work best for me —— perhaps changing it as I go along in my project.





(Of course, I don't mean *me* here, I am thinking about the experience of a typical user of these tools -- of the hundred of people I talk to about layout CSS each month.)
Thanks Jen. We agree and had already filed bug 1359763 for this, which Gabriel has already fixed (has not landed in nightly yet though, probably tomorrow).
So I'll close this as a duplicate for now.

What do you think about bug 1359763 comment 3? In particular this part:
> should the box model in the layout view be collapsed by default if there's a grid on the page?
> I can see 2 problems with it: if we already persisted a state, not restoring it in this case
> would break the expectations. And All other accordions in the app are opened by default (I think).
> Of course the idea behind doing something like is that if there's a grid and people are switching
> to the layout panel for the first time, and they have a rather tiny toolbox, they won't even see
> the grid section at all. 
> Another approach: make the grid section first, and box model section second. Simple, but effective.
> Knowing that the box model is already in the computed view, maybe we can afford to do this.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359763
Oh excellent! Sorry to file a dup. And, uh, to forget that I already raised this issue. (I tend to forget what I said in the past.)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.