error 80004005 when accepting invite (ics format)

RESOLVED INCOMPLETE

Status

defect
RESOLVED INCOMPLETE
2 years ago
6 months ago

People

(Reporter: laurent_roche, Unassigned)

Tracking

Lightning 5.4

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170524180630

Steps to reproduce:

Accepting an invite (ics format) received by e-mail.
The invite does not come from a user running Thunderbird: it looks like he's using Google Calendar.

I am running Thunderbird 52.1.1 on Xubuntu 16.04. My calendar is synchronised with a caldav calendar hosted on a Baikal server.

(I could have chosen component "Import Export" or "Provider: CalDav" ... but I don't know where the error come from)


Actual results:

When clicking on the Accept button I got an error message
(translated from French)
Message processing failed. State : 80004005.

So I clicked on Save button and the message was created ... but I don't think a response was sent to the message sender.


Expected results:

no error, event creation in calendar, reply sent to the invite sender

Comment 1

2 years ago
This is a generic fall back error. Can you please enable calendar.debug.log and calendar.debug.log.verbose, restart TB, reproduce the issue an post the messages you get in the error console?

Also please report the response to the initial OPTIONS reqeust sent to the server after TB startup - you see this in the error console as well with the debug mode enabled.

Also, please attach the email invitation (the whole message, not just the ics part - you can anonymize personal information, but please don't change the structure of the respective data).
Flags: needinfo?(laurent_roche)

Comment 2

2 years ago
Resolving this bug as incomplete for now. If you can provide the requested information, feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(laurent_roche)
Resolution: --- → INCOMPLETE

Comment 3

9 months ago
I run into the same error when receiving google calendar invites.

I am running Thunderbird 52.9.1 on Ubuntu 18.04 and my calendar is synchronized with a caldav calendar as well.
Lightning version 5.4

@[:MakeMyDay] can you quickly summarize how i can enable calendar.debug.log and calendar.debug.log.verbose and to which error log you refer?
Flags: needinfo?(makemyday)

Comment 4

9 months ago
Open config editor from TB options at Advanced > General (menu Options > Options), type or copy the mentioned prefs (if not existing, just create them as boolean pref) into the search box and enable them. Restart TB. Open the error console (menu Tools > Developer Tools > Error Console).
Flags: needinfo?(makemyday)

Comment 5

9 months ago
(In reply to [:MakeMyDay] from comment #4)
> Open config editor from TB options at Advanced > General (menu Options >
> Options), type or copy the mentioned prefs (if not existing, just create
> them as boolean pref) into the search box and enable them. Restart TB. Open
> the error console (menu Tools > Developer Tools > Error Console).

Thanks!


Here the error I get:

iTIP method: REQUEST  calItipUtils.jsm:179:9
iTIP on REQUEST: no existing items.  calItipUtils.jsm:1593:13
iTIP operations: 1  calItipUtils.jsm:1650:9
iTIP options on: REQUEST  calItipUtils.jsm:336:13
CalDAV: itemUri.spec = https://posteo.de:8443/calendars/a.hochlehnert/default/1fhds6fmjksnmr98dqd3ec2r0q%40google.com.ics  calDavCalendar.js:654:9
CalDAV: Item added to Default successfully  calDavCalendar.js:682:21
CalDAV: Get failed: CalDAV: Error: got status 404 fetching calendar data for Default, [xpconnect wrapped calIOperationListener]  calDavCalendar.js:1223:9
Assert failed: error on iTIP processing
2: [resource://calendar/modules/calItipUtils.jsm:1188] ItipOpListener.prototype.onOperationComplete
3: [resource://calendar/modules/calUtils.jsm -> file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js:674] calCachedCalendar.prototype.adoptItem/cacheListener.onOperationComplete
4: [resource://calendar/modules/calProviderUtils.jsm:632] cal.ProviderBase.prototype.notifyPureOperationComplete
5: [resource://calendar/modules/calProviderUtils.jsm:640] cal.ProviderBase.prototype.notifyOperationComplete
6: [file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:1232] calDavCalendar.prototype.notifyGetFailed
7: [resource://calendar/modules/calUtils.jsm -> file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:755] multigetSyncHandler.prototype.onStartRequest
8: [file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:360] oauthCheck
  calUtils.js:1021
	ASSERT file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1021:9
	ItipOpListener.prototype.onOperationComplete resource://calendar/modules/calItipUtils.jsm:1188:9
	calCachedCalendar.prototype.adoptItem/cacheListener.onOperationComplete file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js:674:21
	cal.ProviderBase.prototype.notifyPureOperationComplete resource://calendar/modules/calProviderUtils.jsm:632:17
	cal.ProviderBase.prototype.notifyOperationComplete resource://calendar/modules/calProviderUtils.jsm:640:9
	calDavCalendar.prototype.notifyGetFailed file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:1232:9
	multigetSyncHandler.prototype.onStartRequest file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:755:13
	bound  self-hosted:918:17
	oauthCheck file:///home/andreas/.thunderbird/kflploua.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:360:28
	bound oauthCheck self-hosted:960:17
There has been an error reading data for calendar: Default.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80004005. Description: CalDAV: Error: got status 404 fetching calendar data for Default, [xpconnect wrapped calIOperationListener]  calCalendarManager.js:969:13
There has been an error reading data for calendar: Default.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description:   calCalendarManager.js:969:13
http channel Listener OnDataAvailable contract violation
aChangeLogListener=undefined
calendarURI=https://posteo.de:8443/calendars/a.hochlehnert/default/ 
iscached=true
this.mQueuedQueries.length=0  calDavCalendar.js:1186:9
CalDAV: onStopRequest: no reader

Comment 6

9 months ago
Posted image Error Log Picture

Comment 8

9 months ago
Hmm you mentioned the initial options request. It looks like this:

CalDAV: send: OPTIONS https://posteo.de:8443/calendars/xxxxxxxx/  calDavCalendar.js:1932:13
CalDAV: DAV header: 1, 3, addressbook, access-control, calendar-access, calendar-proxy  calDavCalendar.js:1959:21
CalDAV: Server does not support CalDAV scheduling.

Probably that is the problem?

Comment 9

9 months ago
> CalDAV: send: OPTIONS https://posteo.de:8443/calendars/xxxxxxxx/ 
> calDavCalendar.js:1932:13
> CalDAV: DAV header: 1, 3, addressbook, access-control, calendar-access,
> calendar-proxy  calDavCalendar.js:1959:21
> CalDAV: Server does not support CalDAV scheduling.
> 
> Probably that is the problem?

No, in that case we're doing email scheduling as usual independent of the server. Fornm the log in comment 5 it looks that the event could be stored on the server but re-retrieved when requested.

What calendar server product is that? Do you have an alternate access channel to the calendar? If so, could you check whether the event got stored and if so, whether the details, especially the UID is the same that it had when creating the event in TB?

If it's the same, can you please clear the error console, reproduce the issue and attach all of the details you're getting in the error console until reproducing is completed? Before doing so, please check that offline support is disabled for that calendar (calendar properties, available from the context menu in the calendar list in calendar view) - if it isn't please diabled it and restart TB first.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(an.h)
Resolution: INCOMPLETE → ---

Updated

8 months ago
Whiteboard: [closeme 2018-09-08]

Comment 10

7 months ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago7 months ago
Flags: needinfo?(an.h)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2018-09-08]

Comment 11

6 months ago
I have the same problem. But it is combined with random disappearing calendar events and some events failing to synch which I need help to find a way to systematically reproduce. 
I'm using CalDav and Lightning v6.2.2.1 on Ubuntu 18.04 with TB 60.2.1 (64-bit). 

Here is the error log:
 Lightning:CalDAV: Unexpected status adding item to work: 200
BEGIN:VCALENDAR

PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN

VERSION:2.0

BEGIN:VTIMEZONE

TZID:(UTC+01:00) Amsterdam\, Berlin\, Bern\, Rom\, Stockholm\, Wien

BEGIN:STANDARD

DTSTART:16010101T030000

TZOFFSETFROM:+0200

TZOFFSETTO:+0100

RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10

END:STANDARD

BEGIN:DAYLIGHT

DTSTART:16010101T020000

TZOFFSETFROM:+0100

TZOFFSETTO:+0200

RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3

END:DAYLIGHT

END:VTIMEZONE

BEGIN:VEVENT

LAST-MODIFIED:20181109T113157Z

DTSTAMP:20181109T113157Z

UID:040000008200E00074C5B7101A82E0080000000039B33C2A3E77D40100000000000000

 001000000034CEAEC49E43234692AA20B888AAF486

SUMMARY:Studieplan - Johan Linåker

PRIORITY:5

STATUS:CONFIRMED

ORGANIZER;CN=Johan Linåker;SCHEDULE-AGENT=CLIENT:mailto:johan.linaker@cs.

 lth.se

ATTENDEE;RSVP=TRUE;CN=Krzysztof Kuchcinski;PARTSTAT=NEEDS-ACTION;ROLE=REQ-

 PARTICIPANT:mailto:krzysztof.kuchcinski@cs.lth.se

ATTENDEE;RSVP=TRUE;CN=Björn Regnell;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPAN

 T:mailto:bjorn.regnell@cs.lth.se

ATTACH:CID:0633D7DB7601038DA0D03D406243C8C2D3067CA4@uw.lu.se

DTSTART;TZID="(UTC+01:00) Amsterdam, Berlin, Bern, Rom, Stockholm, Wien":2

 0181120T141500

DTEND;TZID="(UTC+01:00) Amsterdam, Berlin, Bern, Rom, Stockholm, Wien":201

 81120T144500

DESCRIPTION;LANGUAGE=sv-SE:\n

CLASS:PUBLIC

TRANSP:OPAQUE

SEQUENCE:2

LOCATION;LANGUAGE=sv-SE:CS Glasburen (E:2405)

X-MICROSOFT-CDO-APPT-SEQUENCE:2

X-MICROSOFT-CDO-OWNERAPPTID:2116763705

X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE

X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY

X-MICROSOFT-CDO-ALLDAYEVENT:FALSE

X-MICROSOFT-CDO-IMPORTANCE:1

X-MICROSOFT-CDO-INSTTYPE:0

X-MICROSOFT-DONOTFORWARDMEETING:FALSE

X-MICROSOFT-DISALLOW-COUNTER:FALSE

X-MICROSOFT-LOCATIONDISPLAYNAME:CS Glasburen (E:2405)

X-MICROSOFT-LOCATIONSOURCE:Resource

X-MICROSOFT-LOCATIONURI:cs_glasburen@resource.lu.se

X-MOZ-RECEIVED-SEQUENCE:2

X-MOZ-RECEIVED-DTSTAMP:20181109T072156Z

END:VEVENT

END:VCALENDAR

  calDavCalendar.js:704
Assert failed: error on iTIP processing
   calUtils.jsm:147
Lightning:CalDAV: Fatal Error doing multiget for work  calDavRequestHandlers.js:826
NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsISAXXMLReader.onDataAvailable]  calDavRequestHandlers.js:818
2018-11-09 12:34:12.434	exquilla.native	INFO	HtmlRequestError messageText: Could not find server responseCode: HtmlStatus0
2018-11-09 12:36:51.055	exquilla.base	INFO	Ews server starting Biff
2018-11-09 12:36:51.266	exquilla.base	INFO	Skip auto resync on folder : Inkorgen, extensions.exquilla.resyncFolderSizeMax less than folder count of : 49187
2018-11-09 12:37:42.474	exquilla.native	INFO	HtmlRequestError messageText: Could not find server responseCode: HtmlStatus0
Lightning:Couldn't find (UTC+01:00) Amsterdam, Berlin, Bern, Rom, Stockholm, Wien calTimezoneService.js:194
uncaught exception: 2147500033

Comment 12

6 months ago
Your issue looks different, can you please file a new bug for it? You should also test with all addons but Lightning disabled (some of the errors in your log are from the Exquilla addon) at best with offline-support disabled for that calendar. Please also mention there what caldav server product you are using and what client the organizer used for sending (open the message source or just attach the email).

Comment 13

6 months ago
Thanks for info.  Yes, happy to file a new bug. Here it is:
https://bugzilla.mozilla.org/show_bug.cgi?id=1506164
You need to log in before you can comment on or make changes to this bug.