stylo: build fails with MSVC 2017

RESOLVED WORKSFORME

Status

P5
normal
RESOLVED WORKSFORME
a year ago
7 months ago

People

(Reporter: cocof35serveur, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 wontfix, firefox57 wontfix, firefox58 verified)

Details

Attachments

(2 attachments)

76.79 KB, text/plain
Details
499.45 KB, text/plain
Details
(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170604111131
(Reporter)

Comment 1

a year ago
Created attachment 8874230 [details]
Stylo error.txt
(Reporter)

Comment 2

a year ago
Firefox Stylo build with MSVC 2017 are broken. I tried to build it with MSVC 2015 and it worked.
Component: Untriaged → Build Config
Product: Firefox → Core
I don't really understand the failure mode here; there's no obvious error that I can see, just a bunch of warnings.  Unless we're passing warnings-as-errors through, somehow?  That seems very unlikely.
Summary: Stylo doesn't build with MSVC 2017 → stylo: build fails with MSVC 2017
P5 because this doesn't block Stylo. We won't be switching from VS2015 to VS2017 before Quantum ships.
Priority: -- → P5
(Reporter)

Comment 5

a year ago
Created attachment 8874391 [details]
full_log.txt

Here is a full log.
I built with VS2017 a few days ago (and Stylo is enabled by default nowadays), so I assume this is working now.
Thanks! Resolving WFM per dmajor's comment 6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → wontfix
status-firefox57: --- → wontfix
status-firefox58: --- → verified
status-firefox-esr52: --- → unaffected
Resolution: --- → WORKSFORME

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.