[Photon] (some?) panels have ~4px blank space at the bottom underneath the footer/content

VERIFIED FIXED in Firefox 56

Status

()

Firefox
Toolbars and Customization
P1
normal
VERIFIED FIXED
3 months ago
20 days ago

People

(Reporter: Sören Hentzschel, Assigned: mikedeboer)

Tracking

(Blocks: 2 bugs)

Trunk
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 verified)

Details

(Whiteboard: [photon-structure][fixed by bug 1354159])

Attachments

(2 attachments)

(Reporter)

Description

3 months ago
Created attachment 8874232 [details]
screenshot3.png

As you can see in the attached screenshot there is a gap on the footer of the history subview of the new library button.

Comment 1

3 months ago
I've also noticed this in the pocket panel. I don't think it's related to the library specifically.
Blocks: 1349210
No longer blocks: 1354155
Summary: [Photon] New library button: gap on footer in history subview → [Photon] (some?) panels have ~4px blank space at the bottom underneath the footer/content
Whiteboard: [photon-structure][triage]

Updated

3 months ago
Flags: qe-verify+
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]

Comment 2

2 months ago
Created attachment 8876450 [details]
uBlock Origin add-on with extra space on menu.

The menu for uBlock Origin has extra space on the top and bottom (see arrows on screenshot). This only happens with Photon enabled. I contacted the developer and here is what he told me:

uBO embed its frame into the Firefox's-provided panel, and that panel has a padding style causing the issue (line 339 in panelUI.css):

/* START photonpanelview adjustments */

#appMenu-popup > .panel-arrowcontainer > .panel-arrowcontent {
  padding: 0;
  border-radius: 0;
}

photonpanelmultiview panelview {
  background: var(--arrowpanel-background);
  padding: 6px 0;
}

When commenting out the padding style above (the 6px one), it renders fine. The padding style above is in addition to the padding style seen in one of the ancestor element (line 328 in panelUI.css):

.cui-widget-panel > .panel-arrowcontainer > .panel-arrowcontent {
  padding: 4px 0;
}

Meaning the resulting padding is 10 pixels with Photon. I doubt this was meant to be this much. One of the two styles probably needs to be revised.

Comment 3

2 months ago
Evidently the developer of uBO fixed the menu problem in his latest beta version.  He mentioned to me that he could fix it but thought that the real fix is for Mozilla to fix their code per the info above.

Updated

2 months ago
Duplicate of this bug: 1372837
Duplicate of this bug: 1373661
As mentioned in Bug 1373661 I think it is the following:


In chrome://browser/skin/customizableui/panelUI.css#339

photonpanelmultiview panelview {
    background: var(--arrowpanel-background);
    padding: 6px 0;
}

Comment 7

2 months ago
(In reply to Jonathan Kingston [:jkt] from comment #6)
> As mentioned in Bug 1373661 I think it is the following:
> 
> 
> In chrome://browser/skin/customizableui/panelUI.css#339
> 
> photonpanelmultiview panelview {
>     background: var(--arrowpanel-background);
>     padding: 6px 0;
> }

Yes, though it is not super straightforward to come up with a selector that does exactly the right thing here. This doesn't just affect add-on views, you also see this on views that have footers (like the history subview).

I think the padding might want to move to the .panel-subview-body, and we may want to reduce the bottom padding if there's a footer.

Updated

2 months ago
Priority: P3 → P2
Whiteboard: [reserve-photon-structure] → [photon-structure]

Comment 8

2 months ago
The fourth patch in bug 1354159 looks set to fix this.
Depends on: 1354159

Comment 9

2 months ago
Should be fixed on m-c as currently building, probably tomorrow's nightly.
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 56

Updated

2 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED

Updated

2 months ago
Whiteboard: [photon-structure] → [photon-structure][fixed by bug 1354159]

Updated

2 months ago
Iteration: --- → 56.2 - Jul 10
Priority: P2 → P1
Verified on Windows, Mac, and Ubuntu.
Status: RESOLVED → VERIFIED
status-firefox56: --- → verified
Flags: qe-verify+
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.