Crash in mozilla::DisplayItemData::AssertDisplayItemData

RESOLVED DUPLICATE of bug 1344579

Status

()

Core
Layout: Web Painting
--
critical
RESOLVED DUPLICATE of bug 1344579
6 months ago
3 months ago

People

(Reporter: philipp, Unassigned)

Tracking

({crash, regression})

55 Branch
Unspecified
Windows
crash, regression
Points:
---

Firefox Tracking Flags

(firefox55 fix-optional, firefox56 fix-optional)

Details

(crash signature)

(Reporter)

Description

6 months ago
This bug was filed from the Socorro interface and is 
report bp-f26076af-4eaa-4802-9b4d-b7e0b0170604.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::DisplayItemData::AssertDisplayItemData(mozilla::DisplayItemData*) 	layout/painting/FrameLayerBuilder.cpp:306
1 	xul.dll 	mozilla::FrameLayerBuilder::GetOldLayerForFrame(nsIFrame*, unsigned int) 	layout/painting/FrameLayerBuilder.cpp:2092
2 	xul.dll 	mozilla::ContainerState::InvalidateForLayerChange(nsDisplayItem*, mozilla::layers::PaintedLayer*) 	layout/painting/FrameLayerBuilder.cpp:4498
3 	xul.dll 	mozilla::ContainerState::FinishPaintedLayerData<<lambda_593feee20c50667d87c0fe33c81e3e5b> >(mozilla::PaintedLayerData&, <lambda_593feee20c50667d87c0fe33c81e3e5b>) 	layout/painting/FrameLayerBuilder.cpp:3160
4 	xul.dll 	mozilla::PaintedLayerDataNode::PopPaintedLayerData() 	layout/painting/FrameLayerBuilder.cpp:2866
5 	xul.dll 	mozilla::PaintedLayerDataNode::PopAllPaintedLayerData() 	layout/painting/FrameLayerBuilder.cpp:2876
6 	xul.dll 	mozilla::PaintedLayerDataNode::Finish(bool) 	layout/painting/FrameLayerBuilder.cpp:2830
7 	xul.dll 	mozilla::PaintedLayerDataNode::FinishChildrenIntersecting(mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&) 	layout/painting/FrameLayerBuilder.cpp:2809
8 	xul.dll 	mozilla::PaintedLayerDataTree::FinishPotentiallyIntersectingNodes(AnimatedGeometryRoot*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*) 	layout/painting/FrameLayerBuilder.cpp:2983
9 	xul.dll 	mozilla::PaintedLayerDataTree::AddingOwnLayer(AnimatedGeometryRoot*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*, unsigned int*) 	layout/painting/FrameLayerBuilder.cpp:2907
10 	xul.dll 	mozilla::ContainerState::ProcessDisplayItems(nsDisplayList*) 	layout/painting/FrameLayerBuilder.cpp:4235
11 	xul.dll 	mozilla::FrameLayerBuilder::BuildContainerLayerFor(nsDisplayListBuilder*, mozilla::layers::LayerManager*, nsIFrame*, nsDisplayItem*, nsDisplayList*, mozilla::ContainerLayerParameters const&, mozilla::gfx::Matrix4x4Typed<mozilla::gfx::UnknownUnits, mozilla::gfx::UnknownUnits> const*, unsigned int) 	layout/painting/FrameLayerBuilder.cpp:5672
12 	xul.dll 	nsDisplayList::PaintRoot(nsDisplayListBuilder*, nsRenderingContext*, unsigned int) 	layout/painting/nsDisplayList.cpp:2154
13 	xul.dll 	nsLayoutUtils::PaintFrame(nsRenderingContext*, nsIFrame*, nsRegion const&, unsigned int, nsDisplayListBuilderMode, nsLayoutUtils::PaintFrameFlags) 	layout/base/nsLayoutUtils.cpp:3727
14 	xul.dll 	mozilla::PresShell::Paint(nsView*, nsRegion const&, unsigned int) 	layout/base/PresShell.cpp:6432
15 	xul.dll 	nsViewManager::ProcessPendingUpdatesPaint(nsIWidget*) 	view/nsViewManager.cpp:481
16 	xul.dll 	nsViewManager::ProcessPendingUpdatesForView(nsView*, bool) 	view/nsViewManager.cpp:413
17 	xul.dll 	nsViewManager::ProcessPendingUpdates() 	view/nsViewManager.cpp:1095
18 	xul.dll 	nsRefreshDriver::Tick(__int64, mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp:1986
19 	xul.dll 	mozilla::RefreshDriverTimer::TickDriver(nsRefreshDriver*, __int64, mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp:331
20 	xul.dll 	mozilla::RefreshDriverTimer::TickRefreshDrivers(__int64, mozilla::TimeStamp, nsTArray<RefPtr<nsRefreshDriver> >&) 	layout/base/nsRefreshDriver.cpp:301
21 	xul.dll 	mozilla::RefreshDriverTimer::Tick(__int64, mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp:323
22 	xul.dll 	mozilla::VsyncRefreshDriverTimer::RunRefreshDrivers(mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp:754
23 	xul.dll 	mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver(mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp:667
24 	xul.dll 	mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::NotifyVsync(mozilla::TimeStamp) 	layout/base/nsRefreshDriver.cpp:568
25 	xul.dll 	mozilla::layout::VsyncChild::RecvNotify(mozilla::TimeStamp const&) 	layout/ipc/VsyncChild.cpp:67
26 	xul.dll 	mozilla::layout::PVsyncChild::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PVsyncChild.cpp:155
27 	xul.dll 	mozilla::ipc::PBackgroundChild::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PBackgroundChild.cpp:1608
28 	xul.dll 	mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) 	ipc/glue/MessageChannel.cpp:2075
29 	xul.dll 	mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message&&) 	ipc/glue/MessageChannel.cpp:2001
30 	xul.dll 	mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask&) 	ipc/glue/MessageChannel.cpp:1870
31 	xul.dll 	mozilla::ipc::MessageChannel::MessageTask::Run() 	ipc/glue/MessageChannel.cpp:1903
32 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1321
33 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/threads/nsThreadUtils.cpp:472
34 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:124
35 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:301
36 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:231
37 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:211
38 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp:156
39 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp:271
40 	xul.dll 	XRE_RunAppShell() 	toolkit/xre/nsEmbedFunctions.cpp:896
41 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:269
42 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:231
43 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:211
44 	xul.dll 	XRE_InitChildProcess(int, char** const, XREChildData const*) 	toolkit/xre/nsEmbedFunctions.cpp:712
45 	firefox.exe 	content_process_main(mozilla::Bootstrap*, int, char** const) 	ipc/contentproc/plugin-container.cpp:64
46 	firefox.exe 	NS_internal_main(int, char**, char**) 	browser/app/nsBrowserApp.cpp:285
47 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:115
48 	firefox.exe 	__scrt_common_main_seh 	f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:253
49 	kernel32.dll 	BaseThreadInitThunk 	
50 	ntdll.dll 	RtlUserThreadStart 	
51 	kernel32.dll 	BasepReportFault 	
52 	kernel32.dll 	BasepReportFault

this signature is showing up in low volume starting in firefox 55.0a1 with a "MOZ_RELEASE_ASSERT(sAliveDisplayItemDatas && sAliveDisplayItemDatas->Contains(aData))" that was added in bug 1358961

Updated

6 months ago
Component: Layout → Layout: Web Painting
Small volume, marking 55 as fix-optional.

Morris, can you look at this new crash from bug 1358961?
status-firefox55: affected → fix-optional
status-firefox56: --- → affected
Flags: needinfo?(mtseng)
Bug 1358961 just move the function from anonymous namespace to the class. So this bug should be dup of Bug 1344579.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(mtseng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1344579
status-firefox56: affected → fix-optional
You need to log in before you can comment on or make changes to this bug.