No toolbarbutton hover state under Classic and High Contrast themes

RESOLVED FIXED in Thunderbird 55.0

Status

Thunderbird
Theme
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 55.0
All
Windows

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

9 months ago
During playing to make the buttons on the tabbar better visible with light LW-temes I found the toolbarbuttons on Classic and HC Windows themes have no feedback when hovering them. This comes from the border removal of buttons in global some time ago.
(Assignee)

Comment 1

9 months ago
Created attachment 8874260 [details] [diff] [review]
toolbarButton.patch

Fixed the hover state by usingn the same styling we used until now only for the -moz-windows-default-theme. The big piece in messenger.css is the indentation change for the removal of the media query.

Win7 uses now also the same styling as the other Windows. This makes the toolbar hover state better visible with light LW-themes and makes it also simpler because we have now only one styling for all Windows versions.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8874260 - Flags: review?(jorgk)

Comment 2

9 months ago
Comment on attachment 8874260 [details] [diff] [review]
toolbarButton.patch

The challenge with these reviews is always to work out what has changed and how to reproduce that change. So here I did:
Switch to a Windows classic theme, notice that for example the toolbar buttons in the compose window, text size, lists, etc. have no hover feedback.

With the patch there is still no feedback for the HTML toolbar in the compose window, so unless I messed up again, there is no r+ here so far :-(
(Assignee)

Comment 3

9 months ago
Ah yes, sorry. This buttons need a treatment too. Patch follows.

Comment 4

9 months ago
So which buttons are already covered by the patch? Let me test those. As I said in comment #2, it's always a challenge to work out what to look at. My work would be much easier if you told me what to look at and supplied a screenshot. However, of course if I "investigate" myself, I find things you haven't thought of ;-)
(Assignee)

Comment 5

9 months ago
Created attachment 8874337 [details] [diff] [review]
toolbarButton.patch v2

It's great when you "investigate" self. Then you find something like in comment 2 where Win7 is different to newer Windows. The default toolbarbutton shows never a border in Classic or HC themes on Win7, the newer Windows show a border. Copied (and adapted) code from quickFilterBar.css to messengercompose.css to show this borders.
Attachment #8874260 - Attachment is obsolete: true
Attachment #8874260 - Flags: review?(jorgk)
Attachment #8874337 - Flags: review?(jorgk)

Comment 6

9 months ago
Comment on attachment 8874260 [details] [diff] [review]
toolbarButton.patch

OK, I checked visual hover feedback on the quickfilter, mail and folder pane toolbars and the HTML toolbar in the compose window.

Let me check it in later, since there is a typo in the commit message.
Attachment #8874260 - Flags: review+
(Assignee)

Comment 7

9 months ago
You gave the r+ on the old patch. If you land the newer patch, then all is good.

Sorry for the typo. :-(

Updated

9 months ago
Attachment #8874260 - Flags: review+

Comment 8

9 months ago
Comment on attachment 8874337 [details] [diff] [review]
toolbarButton.patch v2

Oops.
Attachment #8874337 - Flags: review?(jorgk) → review+

Comment 9

9 months ago
https://hg.mozilla.org/comm-central/rev/b234696ffcf6d082001f47cc8131a5e7a708fd05
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
You need to log in before you can comment on or make changes to this bug.