bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Usernames are appearing in the password fields. And what's the deal with the key symbols?

RESOLVED INVALID

Status

()

Toolkit
Password Manager
RESOLVED INVALID
a year ago
a month ago

People

(Reporter: Keith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

MAIN ISSUE:
On literally ANY website where I have to sign in with a user name, my username (or usernames) appear as a pulldown in the username field, but when I tab to the password field, the USERNAMES appear there as well!

I'm in a Win10 environ.

Other things:
And I don't know what that new key symbol is next to my username, but PLEASE get rid of them. They're really annoying. Or, you know, give us the option to.

Finally, as of several months ago, I noticed that FF slows down, or even crashes, soon after watching videos on YouTube or visiting Facebook. I've checked w/the 3 other people -- one who has a Mac and 2 other people w/PCs (one whose PC has like 16gb RAM and is super-fast); they've all told me they're having this same issue with FF. 


Actual results:

MAIN ISSUE:
I have to SHIFT +TAB to go BACK to the Username field, then shift again to PW field to get the PW to appear.


Expected results:

I should be able to tab to a Username field and tab to the PW field and SEE a PW on 1st try.
(Reporter)

Comment 1

a year ago
I have an image I can send...but I didn't see an UL option to include here.
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core

Comment 2

a year ago
Attach a screenshot here: https://bugzilla.mozilla.org/attachment.cgi?bugid=1370146&action=enter

Updated

a year ago
Flags: needinfo?(bseeingu6)
(Reporter)

Comment 3

a year ago
Created attachment 8885095 [details]
Firefoxweirdness.jpg
Flags: needinfo?(bseeingu6)
(Reporter)

Comment 4

a year ago
Sorry for the huge delay. Had to deal w/job issue last few weeks.

I discovered that this "issue" I've reported is actually a "feature" that you guys at Firefox added to try and help us...but it doesn't look like a helpful feature. It looks like an error.

This is the funny little image I made. I decided one day to let the e-mail address that appeared fill in the PW field, and it turned out to BE the PW. What a terrible design tho', guys.
Yeah, this is basically working as-intended.

I can see how the design might be confusing - but I think the "[key] $username" UI there is supposed to represent "the secret key/password that's associated with $username".  That lets us show this as an autocomplete without trivially revealing your password to shoulder-surfers.

I think this UI was added in bug 1289913, so I'm marking this as blocking that bug, and reclassifying to that component in case people over there think anything needs to be done here.

(In reply to Keith from comment #4)
> What a terrible design tho', guys.

This is needlessly cruel; please try to be constructive in your feedback.
Blocks: 1289913
Component: Layout: Form Controls → Password Manager
Product: Core → Toolkit
Version: 53 Branch → Trunk
The full design includes a footer like we have for Form Autofill and I think adds clarity but we haven't gotten to that yet. When we come back to working on this dropdown we can think about improving the clarity.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.