Mailnews "Get Msgs" and "Print" button text does not glow white when pressed down

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
--
trivial
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Mark Williamson, Assigned: shliang)

Tracking

({modern})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When clicking any of the buttons in mail, they glow white when pressed. This
does not happen for "Get Msg".
(Reporter)

Comment 1

16 years ago
*** Bug 137021 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
I know what you mean!

This has always been the case, but I never bothered to report this small issue.

OS -> All

The text 'Get Msg' does not highlight on mousedown.
It only highlights if you hold down on the little arrow.
OS: Windows XP → All

Comment 3

16 years ago
is this about a disabled Get Msgs button? Dup of bug 111102?
(another, completely different bug about "bump shadow" is bug 124438)

Comment 4

16 years ago
rkaa, nope.
neither of those.
pick any button on the mail toolbar and press down, the text will be highlighted.
this only happens with 'Get Msg' only if you press down on the triangle.
(Reporter)

Comment 5

16 years ago
There is identical behaviour with the "Print" button in Mail. Is this an issue
with pull down buttons?

Comment 6

16 years ago
is this modern theme only?

Comment 7

16 years ago
yes it is. classic doesn't have any highlighting.
(Reporter)

Comment 8

16 years ago
Pinball seems to have this problem as well; it is understandable since it is
evolved from Modern.

Comment 9

16 years ago
changing component, adding to summary
Assignee: sspitzer → shliang
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Themes
Ever confirmed: true
Product: MailNews → Browser
QA Contact: olgam → pmac
Summary: "Get Msg" button does not glow white when pressed down → Mailnews "Get Msgs" and "Print" button text does not glow white when pressed down

Updated

15 years ago
Keywords: modern

Comment 10

15 years ago
I have a patch coming up for this...

Comment 11

15 years ago
Created attachment 123018 [details] [diff] [review]
patch to make buttons with drop-down menus glow white

Patch to make buttons with drop-down menus glow white.

Comment 12

15 years ago
Comment on attachment 123018 [details] [diff] [review]
patch to make buttons with drop-down menus glow white

Requesting review for this patch to make the text under "Get Msgs", "Print" and
"Mark" buttons turn white when active.	This make this buttons consistent with
the rest of the toolbar buttons.
Attachment #123018 - Flags: review?(sspitzer)
Comment on attachment 123018 [details] [diff] [review]
patch to make buttons with drop-down menus glow white

over to shuehan for review.

if this is just for for those two buttons, why toolbar.css?

is it because those buttons have the drop down thing?  (other buttons have
that, why are they ok?)
Attachment #123018 - Flags: superreview?(sspitzer)
Attachment #123018 - Flags: review?(sspitzer)
Attachment #123018 - Flags: review?(shliang)

Comment 14

15 years ago
Seth: All buttons with the drop-down thing show this bug. Try for example the
"Save" and "Attach" button in the Compose window. When you click on them the
button text doesn´t change its color.

Comment 15

15 years ago
Comment on attachment 123018 [details] [diff] [review]
patch to make buttons with drop-down menus glow white

Requesting review from bryner@netscape.com for this simple fix for toolbar
buttons.
Attachment #123018 - Flags: review?(shliang) → review?(bryner)
Comment on attachment 123018 [details] [diff] [review]
patch to make buttons with drop-down menus glow white

r=bryner
Attachment #123018 - Flags: review?(bryner) → review+

Comment 17

14 years ago
This bug is now WFM with a Linux build from today. Probably this was fixed in
some other bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 18

14 years ago
Comment on attachment 123018 [details] [diff] [review]
patch to make buttons with drop-down menus glow white

Removing obsolete sr request.
Attachment #123018 - Flags: superreview?(sspitzer)
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.