Closed Bug 1370237 Opened 3 years ago Closed 3 years ago

Flash Player isn't loaded until removing pluginreg.dat

Categories

(Core :: Plug-ins, defect)

x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 blocking fixed

People

(Reporter: masayuki, Assigned: qdot)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

I cannot load flash player with Nightly (x64) on Win10. However, after removing pluginreg.dat in the profile folder and restart Nightly, I can load it. However, after restarting Nightly again, I cannot load it.

My pluginreg.dat is:

> Generated File. Do not edit.
> 
> [HEADER]
> Version|0.18t|$
> Arch|x86_64-msvc|$
> 
> [PLUGINS]
> NPSWF64_25_0_0_171.dll|$
> C:\WINDOWS\system32\Macromed\Flash\NPSWF64_25_0_0_171.dll|$
> 25.0.0.171|$
> 1496671838340|0|0|0|$
> Shockwave Flash 25.0 r0|$
> Shockwave Flash|$
> 2
> 0|application/x-shockwave-flash|Adobe Flash movie|swf|$
> 1|application/futuresplash|FutureSplash movie|spl|$
> 
> [INVALID]
> C:\Program Files (x86)\Adobe\Adobe Creative Cloud\Utils\npAdobeAAMDetect32.dll|$
> 1490586182000|$
> C:\Program Files (x86)\Adobe\Adobe Creative Cloud\Utils\npAdobeAAMDetect64.dll|$
> 1490586182000|$
> C:\PROGRA~1\MICROS~2\Office14\NPAUTHZ.DLL|$
> 1263040708000|$
> C:\Program Files\Microsoft Silverlight\5.1.50906.0\npctrl.dll|$
> 1489062234000|$
> C:\Program Files\Microsoft Silverlight\5.1.50906.0\npctrlui.dll|$
> 1489062234000|$
> C:\Program Files\Java\jre1.8.0_121\bin\plugin2\npjp2.dll|$
> 1489671836475|$
> C:\Program Files\Java\jre1.8.0_121\bin\dtplugin\npdeployJava1.dll|$
> 1489671835678|$
> C:\Program Files\Tracker Software\PDF Editor\npPDFXEditPlugin.x86.dll|$
> 1480312858000|$
> C:\Program Files\Tracker Software\PDF Editor\npPDFXEditPlugin.x64.dll|$
> 1480312884000|$
> C:\Users\<user name>\AppData\Local\Google\Update\1.3.33.5\npGoogleUpdate3.dll|$
> 1493468967603|$
Masayuki, does any of the Flash-related data in that pluginreg file look incorrect? In particular C:\WINDOWS\system32\Macromed\Flash\NPSWF64_25_0_0_171.dll 25.0.0.171

What are the symptoms when you cannot load Flash?
* Does Flash appear in about:plugins?
* Obviously it doesn't show up in your test page, but are there any interesting messages? If Flash *does* show up in about:plugins but not on the page, an NSPR log with IPCPlugins:5,PluginNPN:5,PluginNPP:5,Plugin:5
Flags: needinfo?(masayuki)
I'm experiencing similar behaviour on my OS X machine. Here's my pluginreg.dat:


-- snip --


Generated File. Do not edit.

[HEADER]
Version:0.18t:$
Arch:x86_64-gcc3:$

[PLUGINS]
Flash Player.plugin:$
/Library/Internet Plug-Ins/Flash Player.plugin:$
25.0.0.171:$
1494423338000:0:0:0:$
Shockwave Flash 25.0 r0:$
Shockwave Flash:$
2
0:application/x-shockwave-flash:Shockwave Flash:swf:$
1:application/futuresplash:FutureSplash Player:spl:$

[INVALID]
/Library/Internet Plug-Ins/AdobePDFViewer.plugin:$
1378384937000:$
/Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin:$
1378384944000:$
/Library/Internet Plug-Ins/Quartz Composer.webplugin:$
1410301211000:$
/Library/Internet Plug-Ins/VLC Plugin.plugin:$
1429042932000:$
/Library/Internet Plug-Ins/Default Browser.plugin:$
1437098095000:$
/Library/Internet Plug-Ins/googletalkbrowserplugin.plugin:$
1449858085000:$
/Library/Internet Plug-Ins/o1dbrowserplugin.plugin:$
1449858085000:$
/Library/Internet Plug-Ins/Silverlight.plugin:$
1449903684000:$
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin:$
1481605637000:$
/Library/Internet Plug-Ins/Disabled Plug-Ins:$
1482335254000:$
/Library/Internet Plug-Ins/flashplayer.xpt:$
1493264849000:$
/Users/mikeconley/Library/Internet Plug-Ins/npNASAEyes.plugin:$
0:$
/Users/mikeconley/Library/Internet Plug-Ins/.DS_Store:$
1427480984000:$
/Users/mikeconley/Library/Internet Plug-Ins/ZoomUsPlugIn.plugin:$
1473307413000:$


-- snip --

(In reply to Benjamin Smedberg [:bsmedberg] from comment #1)
> What are the symptoms when you cannot load Flash?
> * Does Flash appear in about:plugins?

Yes. Here's the copy-paste:

Shockwave Flash

    File: Flash Player.plugin
    Path: /Library/Internet Plug-Ins/Flash Player.plugin
    Version: 25.0.0.171
    State: Enabled
    Shockwave Flash 25.0 r0

MIME Type	Description	Suffixes
application/x-shockwave-flash	Shockwave Flash	swf
application/futuresplash	FutureSplash Player	spl

> * Obviously it doesn't show up in your test page, but are there any
> interesting messages? If Flash *does* show up in about:plugins but not on
> the page, an NSPR log with IPCPlugins:5,PluginNPN:5,PluginNPP:5,Plugin:5

I'll try to generate that right now, sec....
Not a whole lot going on:



MacBook-Pro-104:mozilla-central mikeconley$ NSPR_LOG_MODULES=IPCPlugins:5,PluginNPN:5,PluginNPP:5,Plugin:5 /Applications/FirefoxNightly.app/Contents/MacOS/firefox -P default
[Main Thread]: I/Plugin LoadCachedPluginsInfo : Loading Cached plugininfo for Flash Player.plugin
[Main Thread]: D/Plugin nsPluginTag::RegisterWithCategoryManager type = application/x-shockwave-flash, removing = no
[Main Thread]: D/Plugin nsPluginTag::RegisterWithCategoryManager type = application/futuresplash, removing = no
I so strongly suspect bug 1337058 that I'm going to hand this directly to qdot. And I think we should back that out for tomorrow's nightly if we can't fix this today.
Assignee: nobody → kyle
Blocks: 1337058
Ok, I'm having the same problem. Gonna see if there's a quick fix, but I'm not super familiar with the plugin registry, so if nothing looks obvious I'll back out and then continue working.
Pretty sure this line in the culprit

http://searchfox.org/mozilla-central/source/dom/plugins/base/nsPluginHost.cpp#2449

I may be running LoadPlugins too early on boot. Had some problems with builds this morning, but once I can verify I may just try to find a place to bring up findplugins later.
Ok, I screwed up epoch setting. I initialize it to zero but took out the point where we bumped it to 1 in the parent process, and since we're loading the cache we don't actually update that again. That's why deleting the pluginreg.dat fixed this, because we wouldn't have cached data to load.

I'm going to guess CI tests don't catch this because we generate a new profile for the tests, so everything gets loaded? Not quite sure how to work around that.
(In reply to Benjamin Smedberg [:bsmedberg] from comment #1)
> Masayuki, does any of the Flash-related data in that pluginreg file look
> incorrect? In particular
> C:\WINDOWS\system32\Macromed\Flash\NPSWF64_25_0_0_171.dll 25.0.0.171

This is correct.

> What are the symptoms when you cannot load Flash?
> * Does Flash appear in about:plugins?

Yes, and the information is correct.

> * Obviously it doesn't show up in your test page, but are there any
> interesting messages? If Flash *does* show up in about:plugins but not on
> the page, an NSPR log with IPCPlugins:5,PluginNPN:5,PluginNPP:5,Plugin:5

Thanks, it's a good information when I find other bugs. But perhaps, looks like the information is not necessary anymore because kmachulis found the cause.

If you still need the log, ping me again.
Flags: needinfo?(masayuki)
I backed out bug 1337058 per comment 4 so that tomorrow's nightly avoids this bug in the mean time.
https://hg.mozilla.org/mozilla-central/rev/3cfe81678881
Duplicate of this bug: 1370143
Comment on attachment 8874595 [details]
Bug 1370237 - Always increment plugin epoch when creating nsPluginHost in parent;

https://reviewboard.mozilla.org/r/145942/#review150244
Attachment #8874595 - Flags: review?(benjamin) → review+
Pushed by kmachulis@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5c7c5f3952e8
Always increment plugin epoch when creating nsPluginHost in parent; r=bsmedberg
https://hg.mozilla.org/mozilla-central/rev/5c7c5f3952e8
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.