If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Quickly over the grid outline kept the cell highlighter and infobars visible

RESOLVED DUPLICATE of bug 1370274

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1370274
4 months ago
4 months ago

People

(Reporter: zer0, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
It might be related to bug 1370274.

It can happens often that both cell highlighters and infobars are still visible once we left the cell area in the grid outline.

That seems because more and more we over the grid ouline, more slow it becomes.

STR:

1. Open a page with a simple grid (e.g. https://gridbyexample.com/examples/code/example1.html)
2. Enabled the grid highlighter and grid outline from the layout panel
3. Quickly move the mouse over the grid's cell in the grid outline.
4. Leave quickly the layout's panel area

In more than few cases, at the step 4 there is a cell that is still highlighted in the page, with both infobars visible.
(Reporter)

Updated

4 months ago
Blocks: 1181227
See Also: → bug 1370274

Updated

4 months ago
Blocks: 1347964
I investigated a little bit. When a mouseover event occurs, we debounce the cell highlighting, which means that it takes a bit of time for it to actually occur. So if you move very quickly, you may trigger a mouseout *before* the cell gets highlighted. So that means it will get highlighted and never un-highlighted, because the mouseout already occurred.

Matteo is adding debouncing for mouseout too in bug 1370274 which might fix this bug, so we better block on that one.
Depends on: 1370274
See Also: bug 1370274
(Reporter)

Comment 2

4 months ago
It's indeed seems fixed by patch of bug 1370274. Thanks for looking into it Patrick!
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370274
You need to log in before you can comment on or make changes to this bug.