Closed Bug 1370443 Opened 5 years ago Closed 5 years ago

Empty objects not visible in JSON Viewer

Categories

(DevTools :: JSON Viewer, defect)

defect
Not set
normal

Tracking

(firefox56 verified)

VERIFIED FIXED
Firefox 56
Tracking Status
firefox56 --- verified

People

(Reporter: Oriol, Assigned: Oriol)

References

Details

Attachments

(1 file, 2 obsolete files)

Load data:application/json,[null,"a"]

null does not appear in the first row until you click.

Load data:application/json,null

The JSON Viewer is blank.
Attached patch json-empty-object.patch (obsolete) — Splinter Review
Attachment #8877857 - Flags: review?(odvarko)
This also affects [] and {}
Summary: null not visible in JSON Viewer → Empty objects not visible in JSON Viewer
Comment on attachment 8877857 [details] [diff] [review]
json-empty-object.patch

Review of attachment 8877857 [details] [diff] [review]:
-----------------------------------------------------------------

Looks reasonable!

Honza
Attachment #8877857 - Flags: review?(odvarko) → review+
Attached patch json-empty-object.patch (obsolete) — Splinter Review
I just noticed that long strings are also considered to have children, so checking that the value is an object is still needed.
Attachment #8877857 - Attachment is obsolete: true
Attachment #8878024 - Flags: review?(odvarko)
Comment on attachment 8878024 [details] [diff] [review]
json-empty-object.patch

Review of attachment 8878024 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8878024 - Flags: review?(odvarko) → review+
Keywords: checkin-needed
Sorry, forgot to run eslint after creating the test.
Attachment #8878024 - Attachment is obsolete: true
Attachment #8878037 - Flags: review?(odvarko)
Keywords: checkin-needed
Attachment #8878037 - Flags: review?(odvarko) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/10706eb84655
Do not hide the summary when expanding an empty object in JSON Viewer. r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/10706eb84655
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Duplicate of this bug: 1327306
I have reproduced this Bug with Nightly 55.0a1 (2017-06-05) on Windows 10, 64 Bit!

The bug's fix is now verified on latest Nightly 56.0a1

Build ID 	20170628030206
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170628]
I have reproduced this bug with Nightly 55.0a1 (2017-06-05) (64-bit) on Ubuntu 16.04 LTS!

This bug's fix is verified with latest Nightly!

Build   ID : 20170629100321
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

[bugday-20170628]
Verified in comment 10 and comment 11.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.