Closed Bug 1370498 Opened 2 years ago Closed 2 years ago

Consider support for adding an image to context menus

Categories

(WebExtensions :: General, enhancement)

54 Branch
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1321544

People

(Reporter: jkt, Unassigned)

Details

To allow extensions to use icons like that we use in containers, can we consider adding another key for context menus to support this for sub menus?

browser.contextMenus.create({
  id: "log-selection",
  title: "Log '%s' to the console",
  contexts: ["selection"],
  icon: "blah.svg"
});

Just to note, this would likely have to force a submenu always as there is already an icon for the extension itself in the parent context menu.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1321544
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.