[modern] tab bar changes height when second tab opened

RESOLVED FIXED

Status

SeaMonkey
Themes
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: John P Baker, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020410
BuildID:    2002041011

Modern theme.
With a single tab open tab bar is 23px high, when second tab is opened
moves down two pixels to 25px high.

Reproducible: Always
Steps to Reproduce:
Modern theme.
1. preferences don't hide the tab bar when only one tab is open
2. open a second tab
3.

Actual Results:  document window moves down two pixels to make room for higher
tab bar.

Expected Results:  tab bar should stay same height - probably 25px otherwise tab
close
button looks wrongly placed when only one tab is opened.
(Reporter)

Comment 1

16 years ago
More obvious when you have "Load links in the background" set
(Reporter)

Comment 2

16 years ago
This would appear to be caused by the close button getting !important
border/padding styles for .toolbarbutton[disabled="true"] when there
is only one tab.

From chrome://global/skin/toolbarbutton.css
(Reporter)

Comment 3

16 years ago
This is confirmed by adding the following to userChrome.css

.tabs-closebutton[disabled="true"] {
/* bug 137057 */
  margin: 0px 4px !important;
  padding: 4px 2px !important;
  border: none !important;
/* bug 137708 */
  list-style-image: url("chrome://global/skin/icons/close-dis.gif") !important;
}
confirming.  raising severity to major, since this breaks some sites by causing
unwanted onresize events.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: review
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 138524 has been marked as a duplicate of this bug. ***
*** Bug 143020 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
What about classic theme?
I can reproduce this with classic, but the summary explicitely mentiones modern.
Is there a separate bug (found none) or should this one be widened?
(Reporter)

Comment 8

16 years ago
Classic theme WFM 2002050706 - the button has
margin: 3px; padding: 2px; border: 2px;
in both states; So probably not the same bug.

Comment 9

16 years ago
*** Bug 145138 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Created attachment 84247 [details] [diff] [review]
Propsed patch

This was the best I could do. It also includes the fix to bug 137708.
(Assignee)

Comment 11

16 years ago
taking
Assignee: shliang → hewitt
(Assignee)

Comment 12

16 years ago
The patch in bug 137708 fixes this also.
Status: NEW → ASSIGNED

Comment 13

16 years ago
*** Bug 146682 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
In comment #4, bzbarsky wrote:

> this breaks some sites by causing unwanted onresize events.

Slightly OT:

If you check the preference for hiding the tab bar when only
one tab is present, then will opening a second tab cause an onresize event?

And if it does, will this also break those sites that you mention?

Comment 15

16 years ago
*** Bug 146498 has been marked as a duplicate of this bug. ***
In response to comment 14, yes and yes.  Not much to be done there -- the 
content area _is_ being resized and I see no way to make that not be so in that 
situation.
*** Bug 148146 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
This appears to be fixed now, thanks to the fix for bug 137708, in the trunk
build for 2002-06-01.
Indeed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 20

16 years ago
*** Bug 171486 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.