Can't load jwplayer in Firefox

RESOLVED WORKSFORME

Status

Air Mozilla
Streaming
RESOLVED WORKSFORME
5 months ago
3 days ago

People

(Reporter: hoosteeno, Unassigned)

Tracking

Details

Environment: 53.0.3 (64-bit) OSX 10.12.5

When I attempt to load a protected stream (https://air.mozilla.org/town-hall-2017-june-town-hall-series-marketing/) as a signed-in employee, the stream fails to load. The web console shows this error:

No jwplayer loaded  event.min.de36040507ab.js:1:12535
GET 
XHR 
https://mozillalives-i.akamaihd.net/hls/live/241431/HTTPS_Restricted/MTV-Commons_720p/chunklist.m3u8 [HTTP/1.1 403 Forbidden 58ms]
[error][hlsjs: could not recover from error after maximum number of attempts, evt hlsError, data [object Object] ]

Without making any changes to my network or environment, I am able to load the same stream as a signed-in employee in Chrome 58.0.3029.110 (64-bit).

I am using a VPN, but I just tested with the VPN disabled and the error persists.
I meant to say "Environment: _Firefox_ 53.0.3 (64-bit)..."

Comment 2

5 months ago
Justin - I located a best practice note regarding a similar issue that recommended enabling third party cookies. Are you running a cookie blocker?
Yes, I'm restricting 3rd-party cookies. If you have a place to test streams, you can just disable 3rd party cookies in Firefox to see if that replicates the issue. I don't have a stream handy or I'd try it.

Comment 4

5 months ago
Can you please try to access the on demand version of this morning's Town Hall at https://air.mozilla.org/town-hall-2017-june-town-hall-series-marketing/ with 3rd-party cookies enabled? The OD behavior in respect to the JW Player should be the same as live. Thanks!
I can't replicate the issue with the on-demand stream. I tried...
* Different channels (nightly/release)
* VPN on/off
* Third-party cookies on/off

The on-demand stream works in all cases.
This is the good place to test that protected live streams work: https://air.mozilla.org/browser-test-stream/

See https://air.mozilla.org/troubleshooting/ about third-party cookies. 

It's not related to VPN in any way. 

One sad thing is that sometimes, it just doesn't work even with third-party cookies disabled. Never been able to reproduce that since a browser refresh almost always works.
This was resolved with the above workarounds.
Status: NEW → RESOLVED
Last Resolved: 3 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.