Closed Bug 1370776 Opened 4 years ago Closed 4 years ago

Intermittent netwerk/test/unit/test_predictor.js | xpcshell return code: 1

Categories

(Core :: Networking, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1370644

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Should be fixed by bug 1370448?


20:01:26     INFO -  TEST-PASS | netwerk/test/unit/test_predictor.js | test_prefetch - [test_prefetch : 54] true == true
20:01:26     INFO -  TEST-PASS | netwerk/test/unit/test_predictor.js | test_prefetch - [test_prefetch : 92] Well this is unexpected... - true == true
20:01:26     INFO -  (xpcshell/head.js) | test run_next_test 9 pending (2)
20:01:26     INFO -  (xpcshell/head.js) | test test_prefetch finished (2)
20:01:26     INFO -  netwerk/test/unit/test_predictor.js | Starting cleanup
20:01:26     INFO -  (xpcshell/head.js) | test cleanup pending (2)
20:01:26     INFO -  (xpcshell/head.js) | test pending (3)
20:01:26     INFO -  (xpcshell/head.js) | test run_next_test 9 finished (3)
20:01:26     INFO -  (xpcshell/head.js) | test run_next_test 10 pending (3)
20:01:26     INFO -  (xpcshell/head.js) | test cleanup finished (3)
20:01:26     INFO -  (xpcshell/head.js) | test finished (2)
20:01:26     INFO -  (xpcshell/head.js) | test run_next_test 10 finished (1)
20:01:26     INFO -  exiting test
20:01:26     INFO -  PID 11844 | ###!!! ERROR: Potential deadlock detected:
20:01:26     INFO -  PID 11844 | === Cyclical dependency starts at
20:01:26     INFO -  PID 11844 | --- Mutex : TimerThread.mMonitor calling context
20:01:26     INFO -  PID 11844 |   [stack trace unavailable]
20:01:26     INFO -  PID 11844 | --- Next dependency:
20:01:26     INFO -  PID 11844 | --- Mutex : nsSocketTransportService::mLock (currently acquired)
20:01:26     INFO -  PID 11844 |  calling context
20:01:26     INFO -  PID 11844 |   [stack trace unavailable]
20:01:26     INFO -  PID 11844 | --- Next dependency:
20:01:26     INFO -  PID 11844 | --- Mutex : nsTimerImpl::mMutex (currently acquired)
20:01:26     INFO -  PID 11844 |  calling context
20:01:26     INFO -  PID 11844 |   [stack trace unavailable]
20:01:26     INFO -  PID 11844 | === Cycle completed at
20:01:26     INFO -  PID 11844 | --- Mutex : TimerThread.mMonitor calling context
20:01:26     INFO -  PID 11844 |   [stack trace unavailable]
20:01:26     INFO -  PID 11844 | Deadlock may happen for some other execution
20:01:26     INFO -  PID 11844 | [11844] ###!!! ASSERTION: Potential deadlock detected:
20:01:26     INFO -  PID 11844 | Cyclical dependency starts at
20:01:26     INFO -  PID 11844 | Mutex : TimerThread.mMonitor
20:01:26     INFO -  PID 11844 | Next dependency:
20:01:26     INFO -  PID 11844 | Mutex : nsSocketTransportService::mLock (currently acquired)
20:01:26     INFO -  PID 11844 | Next dependency:
20:01:26     INFO -  PID 11844 | Mutex : nsTimerImpl::mMutex (currently acquired)
20:01:26     INFO -  PID 11844 | Cycle completed at
20:01:26     INFO -  PID 11844 | Mutex : TimerThread.mMonitor
20:01:26     INFO -  PID 11844 | Deadlock may happen for some other execution
20:01:26     INFO -  PID 11844 | : 'Error', file c:/builds/moz2_slave/autoland-w32-d-000000000000000/build/src/xpcom/threads/BlockingResourceBase.cpp, line 308
20:01:39     INFO -  PID 11844 | #01: mozilla::OffTheBooksMutex::Lock() [xpcom/threads/BlockingResourceBase.cpp:383]
20:01:39     INFO -  PID 11844 | #02: nsTimerImpl::InitCommon(mozilla::BaseTimeDuration<mozilla::TimeDurationValueCalculator> const &,unsigned int,nsTimerImpl::Callback &&) [xpcom/threads/nsTimerImpl.cpp:224]
20:01:39     INFO -  PID 11844 | #03: nsTimerImpl::InitCommon(unsigned int,unsigned int,nsTimerImpl::Callback &&) [xpcom/threads/nsTimerImpl.cpp:203]
20:01:39     INFO -  PID 11844 | #04: nsTimerImpl::Init(nsIObserver *,unsigned int,unsigned int) [xpcom/threads/nsTimerImpl.cpp:328]
20:01:39     INFO -  PID 11844 | #05: nsTimer::Init(nsIObserver *,unsigned int,unsigned int) [xpcom/threads/nsTimerImpl.h:231]
20:01:39     INFO -  PID 11844 | #06: <lambda_7062e026d8d226e0f75f428a0309032c>::operator() [netwerk/base/nsSocketTransportService2.cpp:1626]
20:01:39     INFO -  PID 11844 | #07: mozilla::detail::RunnableFunction<<lambda_7062e026d8d226e0f75f428a0309032c> >::Run() [obj-firefox/dist/include/nsThreadUtils.h:461]
20:01:39     INFO -  PID 11844 | #08: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1370]
20:01:39     INFO -  PID 11844 | #09: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:472]
20:01:39     INFO -  PID 11844 | #10: mozilla::SpinEventLoopUntil<1,<lambda_623e1447a992227477cafe0ed3fddef1> >(<lambda_623e1447a992227477cafe0ed3fddef1> &&,nsIThread *) [obj-firefox/dist/include/nsThreadUtils.h:281]
20:01:39     INFO -  PID 11844 | #11: mozilla::net::nsHttpConnectionMgr::Shutdown() [netwerk/protocol/http/nsHttpConnectionMgr.cpp:245]
20:01:39     INFO -  PID 11844 | #12: mozilla::net::nsHttpHandler::ShutdownConnectionManager() [netwerk/protocol/http/nsHttpHandler.cpp:2622]
20:01:39     INFO -  PID 11844 | #13: nsObserverList::NotifyObservers(nsISupports *,char const *,char16_t const *) [xpcom/ds/nsObserverList.cpp:112]
20:01:39     INFO -  PID 11844 | #14: nsObserverService::NotifyObservers(nsISupports *,char const *,char16_t const *) [xpcom/ds/nsObserverService.cpp:285]
20:01:39     INFO -  PID 11844 | #15: NS_InvokeByIndex
20:01:39     INFO -  PID 11844 | #16: CallMethodHelper::Invoke() [js/xpconnect/src/XPCWrappedNative.cpp:1996]
20:01:39     INFO -  PID 11844 | #17: XPCWrappedNative::CallMethod(XPCCallContext &,XPCWrappedNative::CallMode) [js/xpconnect/src/XPCWrappedNative.cpp:1282]
20:01:39     INFO -  PID 11844 | #18: XPC_WN_CallMethod(JSContext *,unsigned int,JS::Value *) [js/xpconnect/src/XPCWrappedNativeJSOps.cpp:982]
20:01:39     INFO -  PID 11844 | #19: js::CallJSNative(JSContext *,bool (*)(JSContext *,unsigned int,JS::Value *),JS::CallArgs const &) [js/src/jscntxtinlines.h:293]
20:01:39     INFO -  PID 11844 | #20: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:470]
20:01:39     INFO -  PID 11844 | #21: InternalCall [js/src/vm/Interpreter.cpp:515]
20:01:39     INFO -  PID 11844 | #22: js::jit::DoCallFallback [js/src/jit/BaselineIC.cpp:2453]
20:01:39     INFO -  PID 11844 | #23: ??? (???:???)
20:01:39     INFO -  PID 11844 | #24: ??? (???:???)
20:01:39     INFO -  PID 11844 | #25: ??? (???:???)
20:01:39     INFO -  PID 11844 | #26: EnterBaseline [js/src/jit/BaselineJIT.cpp:164]
20:01:39     INFO -  PID 11844 | #27: js::jit::EnterBaselineAtBranch(JSContext *,js::InterpreterFrame *,unsigned char *) [js/src/jit/BaselineJIT.cpp:270]
20:01:39     INFO -  PID 11844 | #28: Interpret [js/src/vm/Interpreter.cpp:2015]
20:01:39     INFO -  PID 11844 | #29: js::RunScript(JSContext *,js::RunState &) [js/src/vm/Interpreter.cpp:410]
20:01:39     INFO -  PID 11844 | #30: js::ExecuteKernel(JSContext *,JS::Handle<JSScript *>,JSObject &,JS::Value const &,js::AbstractFramePtr,JS::Value *) [js/src/vm/Interpreter.cpp:699]
20:01:39     INFO -  PID 11844 | #31: js::Execute(JSContext *,JS::Handle<JSScript *>,JSObject &,JS::Value *) [js/src/vm/Interpreter.cpp:731]
20:01:39     INFO -  PID 11844 | #32: Evaluate [js/src/jsapi.cpp:4662]
20:01:39     INFO -  PID 11844 | #33: JS::Evaluate(JSContext *,JS::ReadOnlyCompileOptions const &,char const *,unsigned int,JS::MutableHandle<JS::Value>) [js/src/jsapi.cpp:4703]
20:01:39     INFO -  PID 11844 | #34: ProcessArgs [js/xpconnect/src/XPCShellImpl.cpp:1131]
20:01:39     INFO -  PID 11844 | #35: XRE_XPCShellMain(int,char * *,char * *,XREShellData const *) [js/xpconnect/src/XPCShellImpl.cpp:1522]
20:01:39     INFO -  PID 11844 | #36: mozilla::BootstrapImpl::XRE_XPCShellMain(int,char * *,char * *,XREShellData const *) [toolkit/xre/Bootstrap.cpp:53]
20:01:39     INFO -  PID 11844 | #37: NS_internal_main(int,char * *,char * *) [js/xpconnect/shell/xpcshell.cpp:74]
20:01:39     INFO -  PID 11844 | #38: wmain [toolkit/xre/nsWindowsWMain.cpp:118]
20:01:39     INFO -  PID 11844 | #39: __scrt_common_main_seh [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:253]
20:01:39     INFO -  PID 11844 | #40: kernel32.dll + 0x53c45
20:01:39     INFO -  PID 11844 | #41: ntdll.dll + 0x637f5
20:01:39     INFO -  PID 11844 | #42: ntdll.dll + 0x637c8
20:01:39     INFO -  PID 11844 | [11844] ###!!! ASSERTION: Potential deadlock detected:
20:01:39     INFO -  PID 11844 | Cyclical dependency starts at
20:01:39     INFO -  PID 11844 | Mutex : TimerThread.mMonitor
20:01:39     INFO -  PID 11844 | Next dependency:
20:01:39     INFO -  PID 11844 | Mutex : nsSocketTransportService::mLock (currently acquired)
20:01:39     INFO -  PID 11844 | Next dependency:
20:01:39     INFO -  PID 11844 | Mutex : nsTimerImpl::mMutex (currently acquired)
20:01:39     INFO -  PID 11844 | Cycle completed at
20:01:39     INFO -  PID 11844 | Mutex : TimerThread.mMonitor
20:01:39     INFO -  PID 11844 | Deadlock may happen for some other execution
20:01:39     INFO -  PID 11844 | : 'Error', file c:/builds/moz2_slave/autoland-w32-d-000000000000000/build/src/xpcom/threads/BlockingResourceBase.cpp, line 308
20:01:39     INFO -  PID 11844 | Hit MOZ_CRASH() at c:/builds/moz2_slave/autoland-w32-d-000000000000000/build/src/memory/mozalloc/mozalloc_abort.cpp:33
See Also: → 1370448
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370644
You need to log in before you can comment on or make changes to this bug.