Closed Bug 1370898 Opened 3 years ago Closed 3 years ago

Error opening/saving images in HTML email if is set to show body as Text only

Categories

(SeaMonkey :: MailNews: General, defect)

SeaMonkey 2.46 Branch
Unspecified
Windows 10
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1331203

People

(Reporter: rumenta71, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213183751

Steps to reproduce:

1) Open Seamonkey
2) Open Mail
3) Set to show email body as Text Only
4) Open an HTML Mail with an image in body or signature
5) Try to save or open from attachments an image

When


Actual results:

If you choose to save image, the file is 0 byte long.
If you choose to open image, in a Seamonkey new tab it shown

The immage "imap://xxx%E2yyy@mail.zzz.it:993/fetch%3EUID%3E/INBOX%3E6440?part=1.2.2&filename=aldjogdpgnmhemoa.png" cant be show because there are errors" (Not sure what is the correct string because I use a localized version)

where imap://xxx%E2yyy@mail.zzz.it is email@server and aldjogdpgnmhemoa.png is the actual image name.


Expected results:

Image is saved and shown in the new tab
I can not reproduce it in 2.252a1. It might have been fixed in bug 1331203. The official 2.49esr is still not ready so you might try Adrians version:

https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-esr-windows32/

Please backup your profile if you want to go back to 2.46 afterwards.
Upps make it 2.52a1 2.252a1 is still some time away :)
NOT reproducible with Server-Installation of unofficial (by FRG) DE SeaMonkey 2.49.1  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20170511042150  (Default Classic Theme) on German WIN7 64bit. I created a minimum email with embedded picture, sent it to an IMAP account (Show body as original HTML), opened attachment image.png with rightclick on imate symbol in Attachment-Pane - works fine.

@reporter:
Please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273)
c) add information 
c1) concerning your Operating System (Version, Distribution, Language)
c2) concerning your SM localization (UI language, Locale setting)
c3) SM settings that might be related to your problems 
    May be you should attach a copy of menu 
   'Help → Trouble shooting information' as a text document
c5) Whether problem persists in Safe Mode without add-ons
c6) Whether problem persists with blank new profile
c7) everything else crossing your mind after you read linked texts
d)  Please send such an email to me after you have asked me by email for my IMAP email
    account 
f) Your Email-Service-Provider
Component: General → MailNews: General
Flags: needinfo?(rumenta71)
OS: Unspecified → Windows 10
(In reply to Rainer Bielefeld from comment #3)
> NOT reproducible with Server-Installation of unofficial (by FRG) DE
> SeaMonkey 2.49.1  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build
> 20170511042150  (Default Classic Theme) on German WIN7 64bit. I created a
> minimum email with embedded picture, sent it to an IMAP account (Show body
> as original HTML), opened attachment image.png with rightclick on imate
> symbol in Attachment-Pane - works fine.


I've tried with Seamonkey 2.49.1 build 20170528085107 and the issue seems to be solved.

Just a tip, with 2.46 the issue is only if you set Show body as plain txt.
Do you still need full information?
Flags: needinfo?(rumenta71)
Confirms my theory that it is fixed by bug 1331203. No other code changes were made in this area.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331203
You need to log in before you can comment on or make changes to this bug.