Closed Bug 1371100 Opened 3 years ago Closed 3 years ago

Intermittent dom/tests/browser/browser_noopener.js | Should have usercontextid set for (#test8|#test11) (private=false, container=true, alwaysNewWindow=true) - Got , expected 1

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: Nika)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:race])

Attachments

(1 file)

This is happening pretty frequently.
Flags: needinfo?(michael)
Summary: Intermittent dom/tests/browser/browser_noopener.js | Should have usercontextid set for #test8 (private=false, container=true, alwaysNewWindow=true) - Got , expected 1 → Intermittent dom/tests/browser/browser_noopener.js | Should have usercontextid set for (#test8|#test11) (private=false, container=true, alwaysNewWindow=true) - Got , expected 1
Duplicate of this bug: 1371124
This is necessary because we asynchronously send the updated UserContextId back
from the child to the parent process, and we would occasionally lose the race on
infrastructure causing us to see the non-updated version.

With this change we explicitly ask the content process, which is not racey.

MozReview-Commit-ID: LODNi1YmBI8
Attachment #8875791 - Flags: review?(bugs)
Attachment #8875791 - Flags: review?(bugs) → review+
Pushed by michael@thelayzells.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/66a83f17d67b
Check userContextId in the content process instead of in the chrome process, r=smaug
Assignee: nobody → michael
Flags: needinfo?(michael)
https://hg.mozilla.org/mozilla-central/rev/66a83f17d67b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Whiteboard: [stockwell fixed:race]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.