Closed Bug 1371204 Opened 4 years ago Closed 4 years ago

Make the image related messages in PWebRenderBridge become asynchronous

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1370681

People

(Reporter: jerry, Unassigned)

References

Details

In profile[1], the sync DeleteImage() message takes 3ms in content process. It's too long comparing with the 5ms for prepareCmd(RenderLayer).

There are some sync messages in PWebRenderBridge. We should examine each sync message if the message is still to be sync.

[1]
https://perf-html.io/public/cc0575a1ff0480138af98f4e2f1d8ef54545c24a/timeline/?range=11.0808_12.4495~11.4042_11.5907~11.4489_11.4878&thread=1
Depends on: webrender
Blocks: webrender
No longer depends on: webrender
I reviewed a patch that did this yesterday, duping.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370681
You need to log in before you can comment on or make changes to this bug.