Closed Bug 1371217 Opened 4 years ago Closed 2 years ago

Top Sites, Bookmarks & History are not centered

Categories

(Firefox for Android :: Theme and Visual Design, defect, P3)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
fennec + ---
firefox-esr68 69+ verified
firefox54 --- wontfix
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- verified

People

(Reporter: bsurd, Assigned: anca.manu)

References

Details

(Keywords: good-first-bug, Whiteboard: [fennec68.1])

Attachments

(3 files)

Attached image portrait.jpg
Devices:  
 - Xiaomi Mi Pad 2 (Android 5.1);
 - Lenovo Yoga Tablet 2 (Android 4.4.2);
 - Nexus 5 (Android 6.0.1).


Steps to reproduce:
1. Open Fennec; 
2. Go to about:home.

Expected result:
 Top Sites, Bookmarks & History panels are centered.

Actual result:
 Top Sites, Bookmarks & History panels are not centered.

Notes:
 The issue is reproducible on all devices not just the ones listed above.
Attached image landscape.jpg
tracking-fennec: --- → ?
Please help prioritize this
Assignee: nobody → cnevinchen
tracking-fennec: ? → +
Flags: needinfo?(wehuang)
Assignee: cnevinchen → nobody
Keywords: good-first-bug
a good first bug should be fine
Flags: needinfo?(wehuang)
Priority: -- → P3

I am an outreachy applicant. Can I work on this?

Assignee: nobody → anca.manu
Status: NEW → ASSIGNED

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:anca.manu, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(anca.manu)
Keywords: checkin-needed
Flags: needinfo?(anca.manu)

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4eaea9067bae
Top Sites, Bookmarks & History are not centered; r=AndreiLazar

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Hi Anca, can you please request uplift for your patch to Fennec 68 Beta? Fennec 68 will be maintained in the ESR 68 channel until mid-2020, so it would be good to have your fix in there. :)

Comment on attachment 9060709 [details]
Bug 1371217 - Top Sites, Bookmarks & History are not centered; r?AndreiLazar

Beta/Release Uplift Approval Request

  • User impact if declined: The users will not be able to see the Sites, Bookmarks and History centered.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps to reproduce:
  1. Open Fennec;
  2. Go to about:home.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The changes are not risky because we did only some small changes, such as centered the Sites, Bookmarks and History
  • String changes made/needed: No strings were added.
Flags: needinfo?(anca.manu)
Attachment #9060709 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9060709 [details]
Bug 1371217 - Top Sites, Bookmarks & History are not centered; r?AndreiLazar

fennec ui fix, approved for 68.0b9

Attachment #9060709 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on Nightly 68.0a1 (2019-06-05) using Samsung Galaxy S8 (Android 9) and Nokia 6 (Android 7.1.1). I'll let the qe-verify + till the verification on Beta, thanks.

Regressions: 1557661

Backed out changeset d6fc2a5a92f2 (Bug 1371217) from beta on suspicion of causing Bug 1557661.

Flags: needinfo?(anca.manu)
Attachment #9060709 - Flags: approval-mozilla-beta+

Petru, maybe you can help here? We're getting close to RC week for 68.

Flags: needinfo?(petru.lingurar)

Verified as fixed on the latest Nightly 69.0a1 (2019-06-20).
Devices:

  • Nokia 6 (Android 7.1.1);
  • Samsung Galaxy Tab S3 (Android 8.0);
  • Xiaomi Mi 8 Lite (Android 8.1).

Also, confirming that the issue is reproducible on the Beta 68.0b11 due to comment 14.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Andrei will resolve the remaining issue in bug 1557661
Removing my NI

Flags: needinfo?(petru.lingurar)
Flags: needinfo?(anca.manu)

Since I fixed the regression, can we uplift both of these tickets?

Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm) → needinfo?(jcristau)

[Tracking Requested - why for this release]:

We should probably postpone uplift until after ESR 68 is branched because this is just a UI layout issue we've had for years.

Comment on attachment 9060709 [details]
Bug 1371217 - Top Sites, Bookmarks & History are not centered; r?AndreiLazar

see comment 10

Attachment #9060709 - Flags: approval-mozilla-esr68?

Comment on attachment 9060709 [details]
Bug 1371217 - Top Sites, Bookmarks & History are not centered; r?AndreiLazar

Fixes a Fennec UI bug. Approved for Fennec 68.1b1.

Attachment #9060709 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+

Comment on attachment 9060709 [details]
Bug 1371217 - Top Sites, Bookmarks & History are not centered; r?AndreiLazar

Whoops, bug 1557661 doesn't have an approval request yet. Putting this back in the queue so both land together.

Attachment #9060709 - Flags: approval-mozilla-esr68+ → approval-mozilla-esr68?

Comment on attachment 9060709 [details]
Bug 1371217 - Top Sites, Bookmarks & History are not centered; r?AndreiLazar

Take two, approved for 68.1b2! This will also be in tomorrow's Nightly builds if QA wants to get a jump start on verifying.

Attachment #9060709 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+

Hi!
Verified as fixed on the latest version of Nightly 68.1a1 (2019-07-10) with the following devices:

  • Huawei MediaPad M2 (Android 5.1.1; Tablet);
  • HTC Desire 820 (Android 6.0.1);
  • Huawei Honor 8 (Android 7.0);
  • Motorola Nexus 6 (Android 7.1.1);
  • Samsung Galaxy Tab S3 (Android 8.0; Tablet).
    We will add the verify flag after we test this on Fennec ESR 68.1b2.
See Also: → 1566337

Hi, verified on Fennec ESR 68.1b2 with devices:

  • Sony Xperia Z3 (Android 5.1.1)
  • Google Pixel 3aXL (Android 9)
  • Samsung Galaxy S9 (Android 8.0.0)
  • Sony Xperia Z5 (Android 7.0)
Whiteboard: [fennec68.1]
You need to log in before you can comment on or make changes to this bug.