Pop-ups not displayed if never show checkbox left unmarked

VERIFIED FIXED in Firefox 68

Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
Last month

People

(Reporter: u549602, Assigned: andrei.a.lazar)

Tracking

55 Branch
Firefox 69
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox54 wontfix, firefox55 wontfix, firefox67 wontfix, firefox67.0.1 wontfix, firefox68 verified, firefox69 verified)

Details

(Whiteboard: [bcs:p2])

Attachments

(1 attachment)

Build: 55.0a1 
Device: Alcatel 1+ (Android 6.0.1)

STR:

1. Go to http://www.popuptest.com/popuptest1.html
2. In the pop-up prevention screen leave "Don't ask again for this site" checkbox unmarked
3. Tap Show

Expected result:
Pop-ups should be displayed 

Actual result:
Pop-ups are not displayed
 
For further details please check https://pastebin.mozilla.org/9024056 and https://www.youtube.com/watch?v=Mi4rOlK49N4
See Also: → 1374989
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5
Assignee: nobody → andrei.a.lazar
Priority: P5 → P2

Added the missing data to the UpdateBlockedPopups event fired from PopupBlockingChild component.

Keywords: checkin-needed

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/425942abf9fd
Pop-ups not displayed if never show checkbox left unmarked r=johannh,petru

Keywords: checkin-needed

Comment on attachment 9065031 [details]
Bug 1371618 Pop-ups not displayed if never show checkbox left unmarked r=JanH

Beta/Release Uplift Approval Request

  • User impact if declined: Popups blocker won't work as expected.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The solution is simple and small and the whole functionality was already implemented.
  • String changes made/needed:
Attachment #9065031 - Flags: approval-mozilla-beta?

Comment on attachment 9065031 [details]
Bug 1371618 Pop-ups not displayed if never show checkbox left unmarked r=JanH

fennec fix, approved for beta68

Attachment #9065031 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Verified with device Lenovo TB3-850M (Android 6.0.0) on Firefox Beta 68.0b7 and Firefox Nightly 68.0a1 (2019-06-03) with status fixed.
I will mark the ticket Verified - Fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.