Visiting skype.com causes a segfault in FF 52.1.0 under CentOS 6.9

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({crash})

52 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213180120

Steps to reproduce:

1. Start firefox in safe mode (firefox --safe-mode)
2. go to skype.com



Actual results:

Firefox displays page momentarily, then dies with a segfault.



Expected results:

Firefox shouldn't have segfaulted.
(Reporter)

Comment 1

a year ago
Running in gdb, I see:

Program received signal SIGSEGV, Segmentation fault.
0x026b2a27 in ?? () from /usr/lib/firefox/libxul.so

Comment 2

a year ago
Any crash reports in the page about:crashes?
If not, could you give a better stacktrace if possible:
https://developer.mozilla.org/en-US/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86

Updated

a year ago
Severity: normal → critical
(Reporter)

Comment 3

a year ago
Unfortunately, I can't run the stock binary of firefox under CentOS 6.9, since it requires GTK3.  I'm using the distribution-supplied binary.  I've submitted a bug report on the CentOS bugzilla:

https://bugs.centos.org/view.php?id=13412

Also, doing some more experimenting, I find that this only seems to affect the 32-bit CentOS firefox binaries, not the 64-bit.

But, all of that seems moot now:  CentOS released an updated binary on June 16 (firefox-52.2.0-1) that seems to have fixed the problem.
(In reply to bugzilla from comment #3)

> But, all of that seems moot now:  CentOS released an updated binary on June
> 16 (firefox-52.2.0-1) that seems to have fixed the problem.

Bugzilla that means this problem is fixed now? Thanks
Flags: needinfo?(bugzilla)
I will mark this as Resolved WFM based on comment 3. Please feel free to reopen or change it if you consider that this status is not the appropriate one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.