Closed Bug 1371723 Opened 2 years ago Closed 2 years ago

Link Sign in to Firefox in Settings to fxa login, not registration

Categories

(Firefox for Android :: Firefox Accounts, defect)

Unspecified
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1229216

People

(Reporter: rfeeley, Unassigned)

References

()

Details

STEPS TO REPRODUCE
- Open settings
- Tap Sign in to Firefox

EXPECTED RESULTS
- FxA login opens

ACTUAL RESULTS
- FxA registration opens


BACKGROUND

We have noticed that on Android, unlike Desktop and iOS, the “Sign in to Firefox” link in Settings links to registration and not login.

I think we should make it behave as it is labelled, and like the other two platforms.

It’s a difficult decision to prove with metrics, because we don’t track how often users have to switch it manually, but I think I have something to share.

We currently allow users (who enter their credentials correctly) to “log in” from the registration form. This is known as signup.signin.success.

It’s an awkward experience as users are likely to fill out their credentials and then scroll down the page to see a “Create account” button. Some won’t notice. Some will and press it anyway. Others will look further down for “Sign in” link.

Ideally we can avoid this.

It looks like in our metrics Android users are over FIVE TIMES more likely to triggers signup.signin.success.

See URL for source
This is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1229216, although whoever actually does the work can also coalesce the tickets.

FWIW, I'm in favour.
Status: NEW → RESOLVED
Closed: 2 years ago
Component: Android Sync → Firefox Accounts
Product: Android Background Services → Firefox for Android
Resolution: --- → DUPLICATE
Duplicate of bug: 1229216
You need to log in before you can comment on or make changes to this bug.