Closed Bug 1371762 Opened 2 years ago Closed 2 years ago

Legacy page shows an experiment

Categories

(Toolkit :: Add-ons Manager, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: andy+bugzilla, Assigned: aswan)

References

Details

(Whiteboard: investigating)

Attachments

(2 files)

On Nightly

1. install a legacy extension
2. install a webextensions experiment
3. turn on the legacy extension pref
4. note that the webextensions experiment appears in the legacy page

This will never happen in release, so prioritize accordingly.

This will only occur if you have at least one legacy extension.
To be clear, step 3 actually means legacy extensions should be disabled right?

I think I might be missing something but experiments are bootstrapped addons so if they are not signed with "Mozilla Extensions" and legacy extensions are disabled, this sounds like everything is working as intended.
Flags: needinfo?(amckay)
But from what I can tell, it hasn't been disabled.
Flags: needinfo?(amckay)
the experiment not being disabled is surprising.  why not and does this impact something else.
Flags: needinfo?(aswan)
Priority: -- → P3
Whiteboard: investigating
Assignee: nobody → aswan
Flags: needinfo?(aswan)
Blocks: 1336576
Attachment #8878696 - Flags: review?(rhelmer)
Attachment #8887996 - Flags: review?(rhelmer)
Comment on attachment 8878696 [details]
Bug 1371762 Part 1 Let cert shim code selectively identify some xpis as privileged

https://reviewboard.mozilla.org/r/150004/#review164894
Attachment #8878696 - Flags: review?(rhelmer) → review+
Comment on attachment 8887996 [details]
Bug 1371762 Part 2 Treat webextension experiments as legacy

https://reviewboard.mozilla.org/r/158870/#review164896
Attachment #8887996 - Flags: review?(rhelmer) → review+
Pushed by rhelmer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/47ebbbac4f99
Part 1 Let cert shim code selectively identify some xpis as privileged r=rhelmer
https://hg.mozilla.org/integration/autoland/rev/7255faf1c8a4
Part 2 Treat webextension experiments as legacy r=rhelmer
https://hg.mozilla.org/mozilla-central/rev/47ebbbac4f99
https://hg.mozilla.org/mozilla-central/rev/7255faf1c8a4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.