Closed Bug 1371801 Opened 3 years ago Closed 2 years ago

Detect if a page can be viewed in reader mode

Categories

(WebExtensions :: Untriaged, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1381992

People

(Reporter: andy+bugzilla, Assigned: bsilverberg)

References

(Blocks 1 open bug)

Details

(Whiteboard: [design-decision-approved] triaged)

Attachments

(1 file)

It would be nice if we could detect if a page has reader mode available or not, since not all pages have this. Perhaps we could add this to the tab API or maybe in the tabs.Tab object.
Priority: -- → P5
Whiteboard: [design-decision-needed] triaged
Whiteboard: [design-decision-needed] triaged → [design-decision-approved] triaged
The internal function that does this in ReaderMode.jsm is called isProbablyReaderable [1], so I would be inclined to use this as the name for our API property as well. It implies that document is probably able to be put into reader mode, but does not guarantee it. It makes sense to make this a property of the Tab object.

Any comments on this?

[1] http://searchfox.org/mozilla-central/rev/cd82cacec2cf734768827ff85ba2dba90a534c5e/toolkit/components/reader/ReaderMode.jsm#184
Assignee: nobody → bob.silverberg
Comment on attachment 8906017 [details]
Bug 1371801 - Detect if a page can be viewed in reader mode,

https://reviewboard.mozilla.org/r/177770/#review182846

Lets wait to land until we have a little more reader support.
Attachment #8906017 - Flags: review?(mixedpuppy)
Duping this to bug 1381992 so I can land everything at once.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1381992
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.